summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES9
-rw-r--r--README16
-rw-r--r--setup.py2
3 files changed, 20 insertions, 7 deletions
diff --git a/CHANGES b/CHANGES
index 1deb19d..64354cd 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,3 +1,12 @@
+Thu Nov 28 18:58:45 MSD 200
+
+Changes to version 2.0.7
+------------------------
+
+- Bugfix to asn1.py, incorrect ASN.1 tag used for UNSIGNED32 type.
+- Bugfix to v1.py & v2c.py modules, GAUGE32 was missing from the
+ list of allowed value-bind types.
+
Fri Sep 20 08:35:43 MSD 2002
Changes to version 2.0.6
diff --git a/README b/README
index 4fc5a52..ab11353 100644
--- a/README
+++ b/README
@@ -1,5 +1,5 @@
-SNMP engine for Python, version 2.0.6
+SNMP engine for Python, version 2.0.7
-------------------------------------
This is a Python implementation of SNMP v.1/v.2c engine. It's general
@@ -19,9 +19,13 @@ license. See the LICENSE file for details.
PRECAUTIONS
-----------
+If you are starting a new project, consider trying the 3.x branch
+of PySNMP which is written in a more standards-compliant way and is
+[hopefully] stable enough by the time of this writing.
+
Unfortunately, version 2.x of PySNMP software is *INCOMPATIBLE* with
-its 1.x branch at the moment. Work on a compatibility layer is being
-in progress.
+its 1.x branch at the moment. For a fully compatible solution, use the
+3.x branch of PySNMP package.
While the pure-Python MIB compiler project is underway, the ASN.1
types of Object IDs associated values must be explicitly specified
@@ -46,13 +50,13 @@ directory in the following way (assuming your Python distribution
resides under /usr/local/lib/python):
$ cd /usr/local/lib/python/site-packages
-$ tar xvf /tmp/pysnmp-2.0.6.tar
-$ echo pysnmp-2.0.6 > pysnmp.pth
+$ tar xvf /tmp/pysnmp-2.0.7.tar
+$ echo pysnmp-2.0.7 > pysnmp.pth
Alternatively, the $PYTHONPATH environment variable can be updated to
point to your PySNMP package location (assuming your UNIX shell is bash):
-export PYTHONPATH=/home/ilya/src/py/pysnmp-2.0.6:$PYTHONPATH
+export PYTHONPATH=/home/ilya/src/py/pysnmp-2.0.7:$PYTHONPATH
The latter trick is also known to work on Windows.
diff --git a/setup.py b/setup.py
index fd5f516..9e6ae5f 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
setup(name="pysnmp",
- version="2.0.6",
+ version="2.0.7",
description="Python SNMP Toolkit",
author="Ilya Etingof",
author_email="ilya@glas.net ",