summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES86
-rw-r--r--LICENSE8
-rw-r--r--README23
-rw-r--r--setup.py19
4 files changed, 97 insertions, 39 deletions
diff --git a/CHANGES b/CHANGES
index 467474e..7243c12 100644
--- a/CHANGES
+++ b/CHANGES
@@ -1,26 +1,70 @@
-Wed Aug 27 22:45:44 MSD 2003
+Wed Feb 18 18:34:05 MSK 2004
+
+Changes to version 3.4.3
+------------------------
+
+- SMI framework implemented. This is to be used to access abstract SNMP
+ management information (MIBs) in various ways.
+- ASN.1 subtyping machinery implemented. Now dynamic ASN.1 instances
+ subtyping and quering becomes available. Previously, this has been done
+ through Python classes inheritance what proved to be a wrong concept.
+ As a side-effect, the low-level API to ASN.1 classes has been changed.
+- ASN.1 codecs framework re-designed and re-implemented aimed at a more
+ consistent design and better performance. Highlights include abstract
+ codec interface and serialized data caching (at encoder).
+- Asn1Object constraints machinery re-implemented based on Mike C. Fletcher's
+ design and code. Now various constrains are implemented as stand-alone
+ objects serving interested Asn1Object derivatives through some abstract
+ protocol (that's probably the Decorator design pattern).
+- Structured pysnmp.asn1.base.* classes reworked to act as proxy objects
+ over Python dictionary for better performance.
+- Many low-level API modifications at pysnmp.asn1.* classes.
+- More tests added at pysnmp.test package.
+- Many minor bugfixes.
+
+Sun Feb 8 19:12:34 MSK 2004
+
+Changes to version 3.4.2
+------------------------
+
+- The pysnmp.test package implemented (pyunit based).
+- Bugfix to pysnmp1.x compatibility API that makes it operational
+ again.
+- Bugfix to None -> Null() value translation at proto.api.generic.
+- Bugfix to OIDs comparation & SNMP error propagation code at
+ proto.api.generic.
+- Bugfix to role.Agent instantiation at asyncrole.Agent code.
+- The VarBindMixIn.apiAlphaSetOidVal() method now does not modify current
+ oid and/or val whenever None's passed as oid and/or val parameters
+ respectively.
+
+Thu Feb 5 18:35:38 MSK 2004
Changes to version 3.4.1
------------------------
-- examples/* tools reworked and moved to apps/ (to act as full-blown
- applications)
-- The mapping.udp.cli.ucd code reworked for a more consistent design.
- API slightly changed in an backward incompatible way.
-- Socket-based transport re-written from the scratch to better
- comply SNMP v3 model. As a result a new API is introduced, Backward
- compatibility is [hopefully] preserved.
-- Various structured ASN.1 objects might not now return newly created
- inner components upon decoding as well as not copying passed objects
- on assignment. As a rule of thumb, all asn1.StructuredAsn1Object derivatives
- are mutable and they deals with object references.
-- Inner components caching implemented at SingleFixedTypeAsn1Object.berDecoder()
- of pysnmp.asn1.encoding.ber for better performance on repetitive operations.
-- Var-binds caching implemented at RequestPduMixIn.apiAlphaSetVarBind() of
- pysnmp.proto.api.alpha.rfc1157 & rfc1905 for better performance on
- repetitive operations.
-
-Mon Sep 1 11:08:30 MSD 2003
+- The examples/* tools reworked to act more like examples while full-blown
+ SNMP tools (along with their CLI and friends) moved to a stand-alone package
+ which is pysnmp-apps available from PySNMP homepage.
+- Components caching implemented at almost all asn1.base.Asn1Object
+ deviratives what aims at significant performance improvement. What is
+ related to this change is that various structured ASN.1 objects might not
+ now return newly created inner components as well as not copying (but
+ borrowing) passed objects on assignment.
+- The pysnmp.mapping.udp.bulkrole module dropped as it looks somewhat
+ redundant to asynrole functionality.
+- Alpha API to pysnmp.proto objects is now the API of choice. Besides
+ other improvements, this package introduces a protocol version-neutral
+ API. Previous Generic API (pysnmp.proto.api.generic) remains for
+ compatibility.
+- Code cleaned up to better comply with coding standards. Particularily,
+ some symbols changed their case, though, aliases set for compatibility.
+- The suggested way to process SNMP responses at role.Agent has been changed
+ to perform complete response processing at the callback function (cbFun).
+ That's why the sendAndReceive() method of role.Agent class now accepts cbCtx
+ parameter.
+
+Thu Oct 30 18:43:44 MSK 2003
Changes to version 3.3.6
------------------------
@@ -33,10 +77,10 @@ Changes to version 3.3.6
handling
Wed Aug 27 22:45:44 MSD 2003
-
+
Changes to version 3.3.5
------------------------
-
+
- The examples/snmp*walk.py tools fixed not to query first OID in range
by GetRequest unless explicitly specified by command line.
- The -C<p|i|c> option implemented at examples/snmp*walk.py tools
diff --git a/LICENSE b/LICENSE
index 120082a..454d13a 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,4 +1,7 @@
-Copyright (c) 1999-2003, Ilya Etingof <ilya@glas.net>, all rights reserved.
+Copyright (c) 1999-2004, Ilya Etingof <ilya@glas.net>, all rights reserved.
+
+THIS SOFTWARE IS NOT FAULT TOLERANT AND SHOULD NOT BE USED IN ANY SITUATION
+ENDANGERING HUMAN LIFE OR PROPERTY.
Redistribution and use in source and binary forms, with or without modification,
are permitted provided that the following conditions are met:
@@ -10,6 +13,9 @@ are permitted provided that the following conditions are met:
list of conditions and the following disclaimer in the documentation and/or
other materials provided with the distribution.
+ * The name of the authors may not be used to endorse or promote products
+ derived from this software without specific prior written permission.
+
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
diff --git a/README b/README
index 10b8d96..c8a829e 100644
--- a/README
+++ b/README
@@ -21,8 +21,6 @@ FEATURES
* Both synchronous and asynchronous IO API support
* Fully documented API with many examples
* Generic, objective ASN.1 framework
-* Partial MIB I/II data types and macros implementation (check
- CVS at SF for recent development)
* 100% Python, works with Python 1.x and later
* MT-safe
@@ -31,7 +29,7 @@ MISFEATURES
* No MIB compiler (though, it's possible to compile ASN.1 code into PySNMP
classes by hand, oh...)
-* No SNMP v.3 support (though, it's almost implemented, check CVS at SF)
+* No SNMP v.3 support (though, it's partially implemented, check CVS at SF)
PRECAUTIONS
-----------
@@ -57,13 +55,13 @@ directory in the following way (assuming your Python distribution
resides under /usr/local/lib/python):
$ cd /usr/local/lib/python/site-packages
-$ tar xvf /tmp/pysnmp-3.3.1.tar
-$ echo pysnmp-3.3.1 > pysnmp.pth
+$ tar xvf /tmp/pysnmp-3.3.5.tar
+$ echo pysnmp-3.3.5 > pysnmp.pth
Alternatively, the $PYTHONPATH environment variable can be updated to
point to your PySNMP package location (assuming your UNIX shell is bash):
-export PYTHONPATH=/home/ilya/src/py/pysnmp-3.3.1:$PYTHONPATH
+export PYTHONPATH=/home/ilya/src/py/pysnmp-3.3.5:$PYTHONPATH
The latter trick is also known to work on Windows.
@@ -71,6 +69,17 @@ I've been told, that on Windows 2000, one needs to go to "Control panel"
-> "System" -> "Advanced" -> "Environment variables" and add/update the
PYTHONPATH environment variable there.
+TESTING
+-------
+
+Once the PySNMP package is installed, try running:
+
+python -c 'from pysnmp.test import suite; suite.run()'
+
+at your command line to make sure the whole thing is working
+properly. Otherwise, please, report all failures to PySNMP mailing
+list (see below).
+
OPERATION
---------
@@ -108,7 +117,7 @@ http://sourceforge.net/projects/pysnmp/
GETTING HELP
------------
-Once anything does not work as expected, please, try browsing PySNMP
+If something does not work as expected, please, try browsing PySNMP
mailing list archives at http://sourceforge.net/mail/?group_id=14735
or post your question there.
diff --git a/setup.py b/setup.py
index 08ffc5c..82de800 100644
--- a/setup.py
+++ b/setup.py
@@ -3,11 +3,11 @@
from distutils.core import setup
setup(name="pysnmp",
- version = "3.4.1",
- description = "Python SNMP Toolkit",
- author = "Ilya Etingof",
- author_email = "ilya@glas.net ",
- url = "http://sourceforge.net/projects/pysnmp/",
+ version="3.4.3",
+ description="Python SNMP Toolkit",
+ author="Ilya Etingof",
+ author_email="ilya@glas.net ",
+ url="http://sourceforge.net/projects/pysnmp/",
packages = [ 'pysnmp',
'pysnmp.asn1',
'pysnmp.asn1.encoding',
@@ -16,15 +16,14 @@ setup(name="pysnmp",
'pysnmp.proto.api',
'pysnmp.proto.api.alpha',
'pysnmp.proto.api.generic',
- 'pysnmp.proto.cli',
- 'pysnmp.proto.cli.ucd',
+ 'pysnmp.test',
'pysnmp.mapping',
'pysnmp.mapping.udp',
+ 'pysnmp.smi',
+ 'pysnmp.smi.macro',
'pysnmp.compat',
'pysnmp.compat.pysnmp1x',
'pysnmp.compat.pysnmp2x',
'pysnmp.compat.snmpy' ],
- data_files = [ ('/usr/local/bin',
- ['apps/pysnmpwalk']) ],
- license = "BSD"
+ license="BSD"
)