summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-06-29 06:14:00 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-06-29 06:14:00 -0700
commite76ec45981646414e3f0a250953133d11dd90a25 (patch)
treed26d0f9f5252fb2497732fe2ad6395dc1c49cb04 /.travis.yml
parentd3597ed4b53a5d13c6296eb24b5a8b1b35489f4a (diff)
parenta06d3dc1831eb39341707ace22999ab3538dd23c (diff)
downloadpystache-e76ec45981646414e3f0a250953133d11dd90a25.tar.gz
Merge branch 'travis-ci' into development: add Travis CI support
Closing pull request #124: https://github.com/defunkt/pystache/pull/124 Thanks, msabramo!
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml16
1 files changed, 16 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..bad487d
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,16 @@
+language: python
+
+# Travis CI has no plans to support Python 2.4 and Jython.
+python:
+ - 2.5
+ - 2.6
+ - 2.7
+ - 3.2
+ # TODO: get all tests passing with PyPy.
+ #- pypy
+
+script:
+ - python setup.py install
+ # Include the spec tests directory for Mustache spec tests and the
+ # project directory for doctests.
+ - pystache-test ext/spec/specs .