summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-03-08 03:07:48 -0800
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-03-08 03:07:48 -0800
commit652b6ccc311fd5c5682e9889cec852a755f88819 (patch)
tree3a42f074f7fdeca9a8604e836c12591e3c8b6942
parent7ccb55fd95f0d16cde6e46774ef80f35c3a3068f (diff)
parentf5217e1dc07b372b48ac73963acf0745a01674ad (diff)
downloadpystache-0.4.0.tar.gz
Merge branch 'v0.4.0-prep' into master (issue #83)v0.4.0
v0.4.0 should now be ready to push to PyPI.
-rw-r--r--MANIFEST.in1
-rw-r--r--setup.py10
2 files changed, 9 insertions, 2 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index 6f910d1..c53247f 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1 +1,2 @@
+include LICENSE
include HISTORY.rst README.rst
diff --git a/setup.py b/setup.py
index ad9981f..5ec959b 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,10 @@
#!/usr/bin/env python
+"""
+Run the following to publish to PyPI:
+
+> python setup.py publish
+
+"""
import os
import sys
@@ -17,7 +23,7 @@ if sys.argv[-1] == "publish":
sys.exit()
setup(name='pystache',
- version='0.3.1',
+ version='0.4.0',
description='Mustache for Python',
long_description=open('README.rst').read() + '\n\n' + open('HISTORY.rst').read(),
author='Chris Wanstrath',
@@ -25,7 +31,7 @@ setup(name='pystache',
url='http://github.com/defunkt/pystache',
packages=['pystache'],
license='MIT',
- classifiers = (
+ classifiers = (
"Development Status :: 4 - Beta",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",