summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-08 17:09:41 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-08 17:09:41 -0700
commit9b167cc11b4f86346cdcd142a8fdcae8fb51146f (patch)
tree3c9dce5b02f7b18e3cd137c9fc52d8745cb22ab4 /README.rst
parentb4881434396bbc1f39d82ec63d7c740c0e838808 (diff)
downloadpystache-9b167cc11b4f86346cdcd142a8fdcae8fb51146f.tar.gz
README formatting.
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst12
1 files changed, 6 insertions, 6 deletions
diff --git a/README.rst b/README.rst
index f277110..4458c19 100644
--- a/README.rst
+++ b/README.rst
@@ -145,7 +145,7 @@ Python 3
--------
For Python 3, we recommend installing and using Distribute_.
-Then one can invoke `Distribute's test`_ command:
+Then one can invoke `Distribute's test`_ command: ::
python setup.py test
@@ -153,26 +153,26 @@ Then one can invoke `Distribute's test`_ command:
Python 2
--------
-For Python 2, we recommend nose_ ::
+For Python 2, we recommend nose_: ::
pip install nose
cd pystache
nosetests
Depending on your Python version and nose installation, you may need
-to type, for example ::
+to type, for example-- ::
nosetests-2.4
-To run all available tests (including doctests)::
+To run all available tests (including doctests)-- ::
nosetests --with-doctest --doctest-extension=rst
-or alternatively (using setup.cfg)::
+or alternatively (using setup.cfg)-- ::
python setup.py nosetests
-To run a subset of the tests, you can use this pattern, for example: ::
+To run a subset of the tests, you can use this pattern, for example-- ::
nosetests --tests tests/test_context.py:GetValueTests.test_dictionary__key_present