summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-05-19 14:18:27 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-05-19 14:18:27 -0700
commit04b2250d67b2f4df518a7574869013705cb1d886 (patch)
treea64fb865024243a8bf2c4129781b408e176424bd /setup.py
parent34b6ebd1f653b32c73c73d3dad49a88e31bd7639 (diff)
downloadpystache-04b2250d67b2f4df518a7574869013705cb1d886.tar.gz
Add code comment to setup.py re: setup() arguments.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 686e27b..08e7183 100644
--- a/setup.py
+++ b/setup.py
@@ -75,8 +75,16 @@ import sys
py_version = sys.version_info
-# Distribute works with Python 2.3.5 and above:
+# distutils does not seem to support the following setup() arguments.
+# It displays a UserWarning when setup() is passed those options:
+#
+# * entry_points
+# * install_requires
+#
+# distribute works with Python 2.3.5 and above:
+#
# http://packages.python.org/distribute/setuptools.html#building-and-distributing-packages-with-distribute
+#
if py_version < (2, 3, 5):
# TODO: this might not work yet.
import distutils as dist