summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-25 23:40:49 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-25 23:40:49 -0700
commit29c7661f9275cd2933a39f4b234b4e391eb94fae (patch)
tree7d066aab994b5b1544f20aa2eafdf673eda3ebe0 /setup.py
parent4007fa33c6078d890f34b15e9b1a0afd9e2ae072 (diff)
downloadpystache-29c7661f9275cd2933a39f4b234b4e391eb94fae.tar.gz
Added commands for tagging to setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 23 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index fe7026c..356b51f 100644
--- a/setup.py
+++ b/setup.py
@@ -4,19 +4,21 @@
"""
This script supports publishing Pystache to PyPI.
-Below are instructions to pystache maintainers on how to push a new
-version of pystache to PyPI--
+This docstring contains instructions to Pystache maintainers on how
+to release a new version of Pystache.
+
+(1) Push to PyPI. To release a new version of Pystache to PyPI--
http://pypi.python.org/pypi/pystache
-Create a PyPI user account. The user account will need permissions to push
-to PyPI. A current "Package Index Owner" of pystache can grant you those
-permissions.
+create a PyPI user account if you do not already have one. The user account
+will need permissions to push to PyPI. A current "Package Index Owner" of
+Pystache can grant you those permissions.
When you have permissions, run the following (after preparing the release,
-bumping the version number in setup.py, etc):
+merging to master, bumping the version number in setup.py, etc):
- > python setup.py publish
+ python setup.py publish
If you get an error like the following--
@@ -33,6 +35,20 @@ as described here, for example:
http://docs.python.org/release/2.5.2/dist/pypirc.html
+(2) Tag the release on GitHub. Here are some commands for tagging.
+
+List current tags:
+
+ git tag -l -n3
+
+Create an annotated tag:
+
+ git tag -a -m "Version 0.5.1" "v0.5.1"
+
+Push a tag to GitHub:
+
+ git push --tags defunkt v0.5.1
+
"""
import os