summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-11 03:55:58 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-11 03:55:58 -0700
commit5f3cb7e0a90474cc3ea6f7bb6918cc950cb01d92 (patch)
tree1547445753e242f2adc5591239a51149a8211bca /setup.py
parent28a74f3c246adeb0951a0bc494349c033245d1c5 (diff)
downloadpystache-5f3cb7e0a90474cc3ea6f7bb6918cc950cb01d92.tar.gz
Separated out the classifiers.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py28
1 files changed, 15 insertions, 13 deletions
diff --git a/setup.py b/setup.py
index 29a00b6..5902d4b 100644
--- a/setup.py
+++ b/setup.py
@@ -61,6 +61,20 @@ HISTORY_PATH = 'HISTORY.rst'
LICENSE_PATH = 'LICENSE'
README_PATH = 'README.rst'
+CLASSIFIERS = (
+ 'Development Status :: 4 - Beta',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2',
+ 'Programming Language :: Python :: 2.4',
+ 'Programming Language :: Python :: 2.5',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.1',
+ 'Programming Language :: Python :: 3.2',
+)
+
def read(path):
"""
@@ -182,19 +196,7 @@ def main(sys_argv):
entry_points = {
'console_scripts': ['pystache=pystache.commands:main'],
},
- classifiers = (
- 'Development Status :: 4 - Beta',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
- 'Programming Language :: Python :: 3.2',
- ),
+ classifiers = CLASSIFIERS,
**extra
)