summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-14 11:47:42 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-14 11:47:42 -0700
commitea76fbdf911a8e8a5a32775067edddc1d95938fc (patch)
treeeb2ae650b5762bf57a1457da5d839d5a63290d73 /setup.py
parent9067814cbb2ce7e70bbfe51d4828691c9970ac89 (diff)
downloadpystache-ea76fbdf911a8e8a5a32775067edddc1d95938fc.tar.gz
Added pystache-test as a console script entry point in setup.py.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index d910383..317d539 100644
--- a/setup.py
+++ b/setup.py
@@ -156,8 +156,11 @@ else:
INSTALL_REQUIRES = requires
+# TODO: decide whether to use find_packages() instead. I'm not sure that
+# find_packages() is available with distutils, for example.
PACKAGES = [
'pystache',
+ 'pystache.commands',
# The following packages are only for testing.
'examples',
'pystache.tests',
@@ -194,7 +197,10 @@ def main(sys_argv):
},
test_suite='pystache.tests',
entry_points = {
- 'console_scripts': ['pystache=pystache.commands.render:main'],
+ 'console_scripts': [
+ 'pystache=pystache.commands.render:main',
+ 'pystache-test=pystache.commands.test:main',
+ ],
},
classifiers = CLASSIFIERS,
**extra