summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-23 17:45:04 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-23 17:45:04 -0700
commitf30aad9ad2a3fd6be307d76c719d13f73d62734e (patch)
tree56540c7d33c62c262ee96a4220c8a0a107f0983e /setup.py
parente05966ee30144a624f88f94ac615e42ff4c5a8ac (diff)
downloadpystache-f30aad9ad2a3fd6be307d76c719d13f73d62734e.tar.gz
Changes in preparation for 0.5.1.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 3 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index bb229f5..6051fba 100644
--- a/setup.py
+++ b/setup.py
@@ -52,10 +52,11 @@ else:
setup = dist.setup
# TODO: use the logging module instead of printing.
-print("Using: version %s of %s" % (repr(dist.__version__), repr(dist)))
+# TODO: include the following in a verbose mode.
+# print("Using: version %s of %s" % (repr(dist.__version__), repr(dist)))
-VERSION = '0.5.1-alpha' # Also change in pystache/init.py.
+VERSION = '0.5.1-alpha' # Also change in pystache/__init__.py.
HISTORY_PATH = 'HISTORY.rst'
LICENSE_PATH = 'LICENSE'
@@ -134,7 +135,6 @@ else:
extra = {
# Causes 2to3 to be run during the build step.
'use_2to3': True,
- 'convert_2to3_doctests': [README_PATH],
}
# We use the package simplejson for older Python versions since Python
@@ -151,8 +151,6 @@ if py_version < (2, 5):
requires.append('simplejson<2.1')
elif py_version < (2, 6):
requires.append('simplejson')
-else:
- requires.append('pyyaml')
INSTALL_REQUIRES = requires
@@ -188,7 +186,6 @@ def main(sys_argv):
'pystache.tests.data.locator': template_files,
'pystache.tests.examples': template_files,
},
- test_suite='pystache.tests',
entry_points = {
'console_scripts': [
'pystache=pystache.commands.render:main',