summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChris Jerdonek <chris.jerdonek@gmail.com>2012-04-08 19:16:21 -0700
committerChris Jerdonek <chris.jerdonek@gmail.com>2012-04-08 19:16:21 -0700
commitf9bda3a5ce2725ca2e2b5a89fbd8a1b1e7642a90 (patch)
tree32326064cec0b5b297f4e3dbf2423e38753b9d65 /setup.py
parentb042d08429b95d76589ea69d14d7a44bcb32c3a1 (diff)
downloadpystache-f9bda3a5ce2725ca2e2b5a89fbd8a1b1e7642a90.tar.gz
More Python 3 unit test fixes; README doctests also now working.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 461e43f..796654e 100644
--- a/setup.py
+++ b/setup.py
@@ -84,6 +84,7 @@ else:
# troubleshoot it while using Python 2.7 instead of Python 3.
extra = {
'use_2to3': True,
+ 'convert_2to3_doctests': ['README.rst'],
}
setup(name='pystache',
@@ -97,6 +98,9 @@ setup(name='pystache',
url='http://github.com/defunkt/pystache',
packages=find_packages(),
package_data = {
+ # Include the README so doctests can be run.
+ # TODO: is there a better way to include the README?
+ 'pystache': ['../README.rst'],
# Include template files so tests can be run.
'examples': template_files,
'pystache.tests.data': template_files,