summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml16
1 files changed, 16 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..bad487d
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,16 @@
+language: python
+
+# Travis CI has no plans to support Python 2.4 and Jython.
+python:
+ - 2.5
+ - 2.6
+ - 2.7
+ - 3.2
+ # TODO: get all tests passing with PyPy.
+ #- pypy
+
+script:
+ - python setup.py install
+ # Include the spec tests directory for Mustache spec tests and the
+ # project directory for doctests.
+ - pystache-test ext/spec/specs .