summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--setup.py12
1 files changed, 8 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index ad9981f..8433c34 100644
--- a/setup.py
+++ b/setup.py
@@ -1,18 +1,22 @@
#!/usr/bin/env python
+# coding: utf-8
import os
import sys
+
try:
from setuptools import setup
except ImportError:
from distutils.core import setup
+
def publish():
"""Publish to Pypi"""
- os.system("python setup.py sdist upload")
+ os.system('python setup.py sdist upload')
+
-if sys.argv[-1] == "publish":
+if sys.argv[-1] == 'publish':
publish()
sys.exit()
@@ -25,12 +29,12 @@ setup(name='pystache',
url='http://github.com/defunkt/pystache',
packages=['pystache'],
license='MIT',
- classifiers = (
+ classifiers = (
"Development Status :: 4 - Beta",
"License :: OSI Approved :: MIT License",
"Programming Language :: Python",
"Programming Language :: Python :: 2.5",
"Programming Language :: Python :: 2.6",
)
- )
+)