summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <james@thegroundwork.com>2015-04-01 12:17:22 -0400
committerJames Socol <james@thegroundwork.com>2015-04-01 12:17:38 -0400
commit8cbda25135ea3db7ed1a14f481880c6465dbd951 (patch)
tree27993f82198cc59ac819fd761f3a493566edd82b
parent852c849b74cae87c80df89aafe0a9fb11bcccae5 (diff)
downloadpystatsd-ipv6-docs.tar.gz
Docs WIPipv6-docs
-rw-r--r--docs/configure.rst14
-rw-r--r--setup.py2
2 files changed, 13 insertions, 3 deletions
diff --git a/docs/configure.rst b/docs/configure.rst
index bc945e3..1201c7c 100644
--- a/docs/configure.rst
+++ b/docs/configure.rst
@@ -26,15 +26,20 @@ They, and their defaults, are::
statsd = StatsClient(host='localhost',
port=8125,
+ ipv6=False,
prefix=None,
maxudpsize=512)
-``host`` is the host running the statsd server. It will support any kind
-of name or IP address you might use.
+``host`` is the host running the statsd server. If a hostname is given,
+will lookup an IP v4 or v6 address based on the value of ``ipv6``. If an
+address is given, the family should match ``ipv6``.
``port`` is the statsd server port. The default for both server and
client is ``8125``.
+``ipv6`` enables the use of IPv6. Since the Etsy server defaults to v4
+only, the default is ``False``.
+
``prefix`` helps distinguish multiple applications or environments using
the same statsd server. It will be prepended to all stats,
automatically. For example::
@@ -60,6 +65,10 @@ on the internet. On a controlled local network or when the statsd server is
running on 127.0.0.1 larger values can decrease the number of UDP packets when
pipelining many metrics. Use with care!
+.. versionchanged:: 3.2
+
+``ipv6`` and
+
In Django
=========
@@ -108,4 +117,5 @@ and then in your Python application, you can simply do::
environment.
.. _statsd: https://github.com/etsy/statsd
+.. _StatsD: https://github.com/etsy/statsd
.. _Django: https://www.djangoproject.com/
diff --git a/setup.py b/setup.py
index a1e3385..2a49f38 100644
--- a/setup.py
+++ b/setup.py
@@ -5,7 +5,7 @@ from setuptools import find_packages, setup
setup(
name='statsd',
- version='3.1',
+ version='3.2',
description='A simple statsd client.',
long_description=open('README.rst').read(),
author='James Socol',