summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2022-11-06 09:53:07 -0500
committerJames Socol <me@jamessocol.com>2022-11-06 09:53:07 -0500
commit76aa84c9a5757026335a950b4a95937432119098 (patch)
tree01c4556d0c2cf42b1e36739ed33774b1ed3648c4
parent1325f31ace0d2f219c5ca4cc3571cb343bd76ca6 (diff)
downloadpystatsd-tools.tar.gz
Add a couple of tools for myselftools
Configures .coveragerc to ignore files that don't matter as well as certain lines. Include a Makefile to remind me how to do releases.
-rw-r--r--.coveragerc13
-rw-r--r--Makefile24
2 files changed, 37 insertions, 0 deletions
diff --git a/.coveragerc b/.coveragerc
new file mode 100644
index 0000000..a139fce
--- /dev/null
+++ b/.coveragerc
@@ -0,0 +1,13 @@
+[run]
+branch = True
+omit =
+ setup.py
+ statsd/tests.py
+ statsd/defaults/*.py
+
+[report]
+exclude_lines =
+ pragma: no cover
+ noqa
+ raise NotImplementedError
+fail_under = 94
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..37e72d5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,24 @@
+.PHONY: test
+test:
+ nose2 statsd --with-coverage
+
+.PHONY: tox
+tox:
+ tox
+
+.PHONY: release
+release: build check
+ twine upload --non-interactive --sign dist/*
+
+.PHONY: clean
+clean:
+ rm -rf dist
+
+.PHONY: build
+build: clean
+ python -m build
+
+
+.PHONY: check
+check:
+ twine check dist/*