summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2018-10-28 17:56:37 -0400
committerGitHub <noreply@github.com>2018-10-28 17:56:37 -0400
commit9f95d1d406d99f7db4d44ef70b74178ca1b5bc03 (patch)
treed39955720ce2b3ca0fd9105686323176cf97b800
parent100046bcd349013d6d78922585621159a33d1ebb (diff)
parent8f1eb3582702fdee1a0653fa43a95d794153f559 (diff)
downloadpystatsd-9f95d1d406d99f7db4d44ef70b74178ca1b5bc03.tar.gz
Merge pull request #118 from michael-k/python3.7
Add support for Python 3.7
-rw-r--r--.travis.yml5
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 7 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 6b955dc..694b6aa 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -6,6 +6,11 @@ python:
- "3.5"
- "3.6"
- "pypy"
+matrix:
+ include:
+ - python: "3.7"
+ dist: xenial
+ sudo: required
install:
- pip install -q "flake8"
script:
diff --git a/setup.py b/setup.py
index edaf82d..4bee288 100644
--- a/setup.py
+++ b/setup.py
@@ -27,6 +27,7 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
'Topic :: Software Development :: Libraries :: Python Modules',
],
)
diff --git a/tox.ini b/tox.ini
index cdd64d4..f75a978 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27,pypy,py34,py35,py36
+envlist = py27,pypy,py34,py35,py36,py37
[testenv]
deps=