summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Clauss <cclauss@me.com>2022-11-05 23:21:40 +0100
committerJames Socol <me@jamessocol.com>2022-11-05 19:41:24 -0400
commitd896c966ed02962ba48174cb54b76da277925c95 (patch)
tree885c08a6a67f47364db80c68d29c25388d8c400a
parentc72ae6032d0cad0545f26e1171e31adc2788e011 (diff)
downloadpystatsd-d896c966ed02962ba48174cb54b76da277925c95.tar.gz
PEP 621: Migrate to pyproject.toml
-rw-r--r--pyproject.toml37
-rw-r--r--setup.cfg2
-rw-r--r--setup.py32
3 files changed, 37 insertions, 34 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..ed8df29
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,37 @@
+[build-system]
+requires = ["setuptools>=61.2"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "statsd"
+version = "3.3.0"
+authors = [{name = "James Socol", email = "james@mozilla.com"}]
+license = {text = "MIT"}
+description = "A simple statsd client."
+readme = "README.rst"
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+]
+urls = {Homepage = "https://github.com/jsocol/pystatsd"}
+
+[tool.distutils.bdist_wheel]
+universal = 1
+
+[tool.setuptools]
+include-package-data = true
+
+[tool.setuptools.packages]
+find = {namespaces = false}
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 2a9acf1..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[bdist_wheel]
-universal = 1
diff --git a/setup.py b/setup.py
deleted file mode 100644
index db88931..0000000
--- a/setup.py
+++ /dev/null
@@ -1,32 +0,0 @@
-from setuptools import find_packages, setup
-
-
-setup(
- name='statsd',
- version='3.3.0',
- description='A simple statsd client.',
- long_description=open('README.rst').read(),
- author='James Socol',
- author_email='james@mozilla.com',
- url='https://github.com/jsocol/pystatsd',
- license='MIT',
- packages=find_packages(),
- include_package_data=True,
- package_data={'': ['README.rst']},
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- ],
-)