summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2022-11-05 19:43:11 -0400
committerGitHub <noreply@github.com>2022-11-05 19:43:11 -0400
commiteda702fb46649d932b6ef0b223a238b1bad64fe5 (patch)
tree810bb5ee9c000db09dbfc964fd4d5d65cec8e685
parentc72ae6032d0cad0545f26e1171e31adc2788e011 (diff)
parentb9c3b06512794e1647755018676b4e2cc54ed47b (diff)
downloadpystatsd-eda702fb46649d932b6ef0b223a238b1bad64fe5.tar.gz
Merge pull request #171 from cclauss/pyproject.toml
PEP 621: Migrate to pyproject.toml
-rw-r--r--pyproject.toml37
-rw-r--r--setup.cfg2
-rw-r--r--setup.py32
-rw-r--r--tox.ini1
4 files changed, 38 insertions, 34 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..ed8df29
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,37 @@
+[build-system]
+requires = ["setuptools>=61.2"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "statsd"
+version = "3.3.0"
+authors = [{name = "James Socol", email = "james@mozilla.com"}]
+license = {text = "MIT"}
+description = "A simple statsd client."
+readme = "README.rst"
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Environment :: Web Environment",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2",
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+]
+urls = {Homepage = "https://github.com/jsocol/pystatsd"}
+
+[tool.distutils.bdist_wheel]
+universal = 1
+
+[tool.setuptools]
+include-package-data = true
+
+[tool.setuptools.packages]
+find = {namespaces = false}
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 2a9acf1..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[bdist_wheel]
-universal = 1
diff --git a/setup.py b/setup.py
deleted file mode 100644
index db88931..0000000
--- a/setup.py
+++ /dev/null
@@ -1,32 +0,0 @@
-from setuptools import find_packages, setup
-
-
-setup(
- name='statsd',
- version='3.3.0',
- description='A simple statsd client.',
- long_description=open('README.rst').read(),
- author='James Socol',
- author_email='james@mozilla.com',
- url='https://github.com/jsocol/pystatsd',
- license='MIT',
- packages=find_packages(),
- include_package_data=True,
- package_data={'': ['README.rst']},
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Environment :: Web Environment',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Operating System :: OS Independent',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Topic :: Software Development :: Libraries :: Python Modules',
- ],
-)
diff --git a/tox.ini b/tox.ini
index 06d6d59..42c4c68 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,6 @@
[tox]
envlist = py37,py38,py39,py310,py311,pypy3
+isolated_build = True
[testenv]
deps=