summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Socol <me@jamessocol.com>2020-10-08 07:46:04 -0400
committerGitHub <noreply@github.com>2020-10-08 07:46:04 -0400
commitf3f304b4b2c3d5eddeb9f4977d9c82c64c37a052 (patch)
treec1d04473c34318fae69dcdc9b90e2941e7699496
parent9d9d9ef211f2c6e911cf325562fd8d35af5157cf (diff)
parent817f2bf3098f92f307ccb1bc047bc9e6382212cb (diff)
downloadpystatsd-f3f304b4b2c3d5eddeb9f4977d9c82c64c37a052.tar.gz
Merge pull request #141 from jsocol/pr/131master
Travis CI: Add Python 3.8 to the testing
-rw-r--r--.travis.yml10
-rw-r--r--setup.py2
2 files changed, 4 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 694b6aa..2ff0fc0 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,16 +1,12 @@
language: python
-sudo: false
python:
- "2.7"
- - "3.4"
- "3.5"
- "3.6"
+ - "3.7"
+ - "3.8"
- "pypy"
-matrix:
- include:
- - python: "3.7"
- dist: xenial
- sudo: required
+ - "pypy3"
install:
- pip install -q "flake8"
script:
diff --git a/setup.py b/setup.py
index 4bee288..197757f 100644
--- a/setup.py
+++ b/setup.py
@@ -24,10 +24,10 @@ setup(
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
'Topic :: Software Development :: Libraries :: Python Modules',
],
)