summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason R. Coombs <jaraco@jaraco.com>2019-11-30 20:12:13 -0500
committerJason R. Coombs <jaraco@jaraco.com>2019-11-30 20:12:13 -0500
commit0880a9876cf424458b82757d1c7504be58f9c2c1 (patch)
tree0e35b6de27a698acd34635fd1f2b7a25c3cdd474
parentd760dfb4093a9492b2e9ff9476c29c71dbe14ae2 (diff)
parent1c187ad0cf50fbc14626f63cb669a9ec5949012f (diff)
downloadpytest-runner-master.tar.gz
Merge https://github.com/jaraco/tideliftmaster
-rw-r--r--.github/FUNDING.yml1
-rw-r--r--README.rst10
-rw-r--r--docs/_templates/tidelift-sidebar.html6
-rw-r--r--docs/conf.py5
-rw-r--r--tox.ini3
5 files changed, 25 insertions, 0 deletions
diff --git a/.github/FUNDING.yml b/.github/FUNDING.yml
new file mode 100644
index 0000000..3b4273a
--- /dev/null
+++ b/.github/FUNDING.yml
@@ -0,0 +1 @@
+tidelift: pypi/pytest-runner
diff --git a/README.rst b/README.rst
index 0a400aa..ba9805b 100644
--- a/README.rst
+++ b/README.rst
@@ -16,6 +16,9 @@
.. .. image:: https://readthedocs.org/projects/pytest-runner/badge/?version=latest
.. :target: https://pytest-runner.readthedocs.io/en/latest/?badge=latest
+.. image:: https://tidelift.com/badges/package/pypi/pytest-runner
+ :target: https://tidelift.com/subscription/pkg/pypi-pytest-runner?utm_source=pypi-pytest-runner&utm_medium=readme
+
Setup scripts can use pytest-runner to add setup.py test support for pytest
runner.
@@ -129,3 +132,10 @@ is invoked::
#... (other setup requirements)
] + pytest_runner,
)
+
+Security Contact
+================
+
+To report a security vulnerability, please use the
+`Tidelift security contact <https://tidelift.com/security>`_.
+Tidelift will coordinate the fix and disclosure.
diff --git a/docs/_templates/tidelift-sidebar.html b/docs/_templates/tidelift-sidebar.html
new file mode 100644
index 0000000..c89c0f0
--- /dev/null
+++ b/docs/_templates/tidelift-sidebar.html
@@ -0,0 +1,6 @@
+<h3 class="donation">Professional support</h3>
+
+<p>
+Professionally-supported {{ project }} is available with the
+<a href="https://tidelift.com/subscription/pkg/pypi-{{ project }}?utm_source=pypi-{{ project }}&utm_medium=readme">Tidelift Subscription</a>.
+</p>
diff --git a/docs/conf.py b/docs/conf.py
index 40166c5..e06bee4 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -28,3 +28,8 @@ link_files = {
],
)
}
+
+# Custom sidebar templates, maps document names to template names.
+html_theme = 'alabaster'
+templates_path = ['_templates']
+html_sidebars = {'index': ['tidelift-sidebar.html']}
diff --git a/tox.ini b/tox.ini
index d267e16..2e22bd3 100644
--- a/tox.ini
+++ b/tox.ini
@@ -32,11 +32,14 @@ deps =
pep517>=0.5
twine>=1.13
path.py
+ jaraco.tidelift
passenv =
TWINE_PASSWORD
+ TIDELIFT_TOKEN
setenv =
TWINE_USERNAME = {env:TWINE_USERNAME:__token__}
commands =
python -c "import path; path.Path('dist').rmtree_p()"
python -m pep517.build .
python -m twine upload dist/*
+ python -m jaraco.tidelift.publish-release-notes