summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--CHANGES.rst5
-rw-r--r--setup.py17
2 files changed, 21 insertions, 1 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index ab8f799..776f320 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -1,3 +1,8 @@
+5.1
+===
+
+* #49: Surgically restore support for older setuptools versions.
+
5.0
===
diff --git a/setup.py b/setup.py
index 827e955..d6459a0 100644
--- a/setup.py
+++ b/setup.py
@@ -2,5 +2,20 @@
import setuptools
+
+compat = dict(
+ name='pytest-runner',
+ py_modules=['ptr'],
+ setup_requires=['setuptools_scm >= 1.15.0'],
+ entry_points={'distutils.commands': ['ptr = ptr:PyTest', 'pytest = ptr:PyTest']},
+)
+"""
+Because pytest-runner is frequently installed by
+setup_requires and thus easy_install, and because
+many systems still run with setuptools prior to
+30.4 in which support for declarative config was
+added, supply the basic metadata here. Ref #49.
+"""
+
if __name__ == "__main__":
- setuptools.setup(use_scm_version=True)
+ setuptools.setup(use_scm_version=True, **compat)