summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index 1e95a0e..8d0f491 100644
--- a/setup.py
+++ b/setup.py
@@ -30,7 +30,7 @@ params = dict(
else []
),
py_modules=['ptr'],
- python_requires='>=2.6',
+ python_requires='>=2.7,!=3.0,!=3.1',
install_requires=[
],
extras_require={
@@ -39,10 +39,6 @@ params = dict(
'pytest-sugar',
'pytest-virtualenv',
],
- 'testing:python_version=="2.6"': [
- # undeclared dependency of pytest-virtualenv
- 'importlib',
- ],
'docs': [
'sphinx',
'jaraco.packaging>=3.2',
@@ -56,7 +52,6 @@ params = dict(
"Development Status :: 5 - Production/Stable",
"Intended Audience :: Developers",
"License :: OSI Approved :: MIT License",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Framework :: Pytest",