summaryrefslogtreecommitdiff
path: root/python_daemon.egg-info
diff options
context:
space:
mode:
authorLorry Tar Creator <lorry-tar-importer@baserock.org>2010-03-02 09:35:54 +0000
committer <>2014-12-08 18:37:23 +0000
commit02378192d5bb4b16498d87ace57da425166426bf (patch)
tree2e940dd7284d31c7d32808d9c6635a57547363cb /python_daemon.egg-info
downloadpython-daemon-02378192d5bb4b16498d87ace57da425166426bf.tar.gz
Imported from /home/lorry/working-area/delta_python-packages_python-daemon/python-daemon-1.5.5.tar.gz.python-daemon-1.5.5
Diffstat (limited to 'python_daemon.egg-info')
-rw-r--r--python_daemon.egg-info/PKG-INFO37
-rw-r--r--python_daemon.egg-info/SOURCES.txt22
-rw-r--r--python_daemon.egg-info/dependency_links.txt1
-rw-r--r--python_daemon.egg-info/not-zip-safe1
-rw-r--r--python_daemon.egg-info/requires.txt2
-rw-r--r--python_daemon.egg-info/top_level.txt1
6 files changed, 64 insertions, 0 deletions
diff --git a/python_daemon.egg-info/PKG-INFO b/python_daemon.egg-info/PKG-INFO
new file mode 100644
index 0000000..df8f553
--- /dev/null
+++ b/python_daemon.egg-info/PKG-INFO
@@ -0,0 +1,37 @@
+Metadata-Version: 1.0
+Name: python-daemon
+Version: 1.5.5
+Summary: Library to implement a well-behaved Unix daemon process.
+Home-page: http://pypi.python.org/pypi/python-daemon/
+Author: Ben Finney
+Author-email: ben+python@benfinney.id.au
+License: PSF-2+
+Description: This library implements the well-behaved daemon specification of
+ :pep:`3143`, "Standard daemon process library".
+
+ A well-behaved Unix daemon process is tricky to get right, but the
+ required steps are much the same for every daemon program. A
+ `DaemonContext` instance holds the behaviour and configured
+ process environment for the program; use the instance as a context
+ manager to enter a daemon state.
+
+ Simple example of usage::
+
+ import daemon
+
+ from spam import do_main_program
+
+ with daemon.DaemonContext():
+ do_main_program()
+
+ Customisation of the steps to become a daemon is available by
+ setting options on the `DaemonContext` instance; see the
+ documentation for that class for each option.
+Keywords: daemon,fork,unix
+Platform: UNKNOWN
+Classifier: Development Status :: 4 - Beta
+Classifier: License :: OSI Approved :: Python Software Foundation License
+Classifier: Operating System :: POSIX
+Classifier: Programming Language :: Python
+Classifier: Intended Audience :: Developers
+Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff --git a/python_daemon.egg-info/SOURCES.txt b/python_daemon.egg-info/SOURCES.txt
new file mode 100644
index 0000000..ab2b523
--- /dev/null
+++ b/python_daemon.egg-info/SOURCES.txt
@@ -0,0 +1,22 @@
+ChangeLog
+LICENSE.GPL-2
+LICENSE.PSF-2
+MANIFEST.in
+setup.py
+daemon/__init__.py
+daemon/daemon.py
+daemon/pidlockfile.py
+daemon/runner.py
+daemon/version/__init__.py
+daemon/version/version_info.py
+python_daemon.egg-info/PKG-INFO
+python_daemon.egg-info/SOURCES.txt
+python_daemon.egg-info/dependency_links.txt
+python_daemon.egg-info/not-zip-safe
+python_daemon.egg-info/requires.txt
+python_daemon.egg-info/top_level.txt
+test/__init__.py
+test/scaffold.py
+test/test_daemon.py
+test/test_pidlockfile.py
+test/test_runner.py \ No newline at end of file
diff --git a/python_daemon.egg-info/dependency_links.txt b/python_daemon.egg-info/dependency_links.txt
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/python_daemon.egg-info/dependency_links.txt
@@ -0,0 +1 @@
+
diff --git a/python_daemon.egg-info/not-zip-safe b/python_daemon.egg-info/not-zip-safe
new file mode 100644
index 0000000..8b13789
--- /dev/null
+++ b/python_daemon.egg-info/not-zip-safe
@@ -0,0 +1 @@
+
diff --git a/python_daemon.egg-info/requires.txt b/python_daemon.egg-info/requires.txt
new file mode 100644
index 0000000..1c7ae21
--- /dev/null
+++ b/python_daemon.egg-info/requires.txt
@@ -0,0 +1,2 @@
+setuptools
+lockfile >=0.7 \ No newline at end of file
diff --git a/python_daemon.egg-info/top_level.txt b/python_daemon.egg-info/top_level.txt
new file mode 100644
index 0000000..28e3ee0
--- /dev/null
+++ b/python_daemon.egg-info/top_level.txt
@@ -0,0 +1 @@
+daemon