summaryrefslogtreecommitdiff
path: root/python_daemon.egg-info
diff options
context:
space:
mode:
Diffstat (limited to 'python_daemon.egg-info')
-rw-r--r--python_daemon.egg-info/PKG-INFO21
-rw-r--r--python_daemon.egg-info/SOURCES.txt12
-rw-r--r--python_daemon.egg-info/requires.txt2
3 files changed, 18 insertions, 17 deletions
diff --git a/python_daemon.egg-info/PKG-INFO b/python_daemon.egg-info/PKG-INFO
index df8f553..352c1ba 100644
--- a/python_daemon.egg-info/PKG-INFO
+++ b/python_daemon.egg-info/PKG-INFO
@@ -1,13 +1,13 @@
-Metadata-Version: 1.0
+Metadata-Version: 1.1
Name: python-daemon
-Version: 1.5.5
+Version: 1.6.1
Summary: Library to implement a well-behaved Unix daemon process.
Home-page: http://pypi.python.org/pypi/python-daemon/
Author: Ben Finney
Author-email: ben+python@benfinney.id.au
-License: PSF-2+
+License: Apache-2
Description: This library implements the well-behaved daemon specification of
- :pep:`3143`, "Standard daemon process library".
+ :pep:`3143`, “Standard daemon process library”.
A well-behaved Unix daemon process is tricky to get right, but the
required steps are much the same for every daemon program. A
@@ -17,12 +17,12 @@ Description: This library implements the well-behaved daemon specification of
Simple example of usage::
- import daemon
+ import daemon
- from spam import do_main_program
+ from spam import do_main_program
- with daemon.DaemonContext():
- do_main_program()
+ with daemon.DaemonContext():
+ do_main_program()
Customisation of the steps to become a daemon is available by
setting options on the `DaemonContext` instance; see the
@@ -30,8 +30,9 @@ Description: This library implements the well-behaved daemon specification of
Keywords: daemon,fork,unix
Platform: UNKNOWN
Classifier: Development Status :: 4 - Beta
-Classifier: License :: OSI Approved :: Python Software Foundation License
+Classifier: License :: OSI Approved :: Apache Software License
Classifier: Operating System :: POSIX
-Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 2.6
+Classifier: Programming Language :: Python :: 2.7
Classifier: Intended Audience :: Developers
Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff --git a/python_daemon.egg-info/SOURCES.txt b/python_daemon.egg-info/SOURCES.txt
index ab2b523..7b3281a 100644
--- a/python_daemon.egg-info/SOURCES.txt
+++ b/python_daemon.egg-info/SOURCES.txt
@@ -1,22 +1,22 @@
ChangeLog
-LICENSE.GPL-2
-LICENSE.PSF-2
+LICENSE.ASF-2
+LICENSE.GPL-3
MANIFEST.in
setup.py
daemon/__init__.py
daemon/daemon.py
-daemon/pidlockfile.py
+daemon/pidfile.py
daemon/runner.py
daemon/version/__init__.py
daemon/version/version_info.py
+doc/FAQ
+doc/TODO
python_daemon.egg-info/PKG-INFO
python_daemon.egg-info/SOURCES.txt
python_daemon.egg-info/dependency_links.txt
python_daemon.egg-info/not-zip-safe
python_daemon.egg-info/requires.txt
python_daemon.egg-info/top_level.txt
-test/__init__.py
-test/scaffold.py
test/test_daemon.py
-test/test_pidlockfile.py
+test/test_pidfile.py
test/test_runner.py \ No newline at end of file
diff --git a/python_daemon.egg-info/requires.txt b/python_daemon.egg-info/requires.txt
index 1c7ae21..29777cf 100644
--- a/python_daemon.egg-info/requires.txt
+++ b/python_daemon.egg-info/requires.txt
@@ -1,2 +1,2 @@
setuptools
-lockfile >=0.7 \ No newline at end of file
+lockfile >=0.9