summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Simionato <michele.simionato@gmail.com>2021-10-13 05:49:34 +0200
committerGitHub <noreply@github.com>2021-10-13 05:49:34 +0200
commitd37eebca8c7b094d65c696aec6bc89a9df50324f (patch)
treef800314aa28f10e612b39d4bbff6d76b905f729b
parent0094c7b282a45aaa234f14b90984ccdc350dc6c5 (diff)
parent7002507b86f90a79777d65129e39c4cce96587e2 (diff)
downloadpython-decorator-git-d37eebca8c7b094d65c696aec6bc89a9df50324f.tar.gz
Merge pull request #134 from hugovk/master
Add support for Python 3.10
-rw-r--r--.github/workflows/python-package.yml2
-rw-r--r--docs/documentation.md2
-rw-r--r--setup.py1
-rw-r--r--src/tests/documentation.py2
4 files changed, 4 insertions, 3 deletions
diff --git a/.github/workflows/python-package.yml b/.github/workflows/python-package.yml
index 6ded973..d527946 100644
--- a/.github/workflows/python-package.yml
+++ b/.github/workflows/python-package.yml
@@ -15,7 +15,7 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python-version: ['3.5', '3.6', '3.7', '3.8', '3.9']
+ python-version: ['3.5', '3.6', '3.7', '3.8', '3.9', '3.10']
steps:
- uses: actions/checkout@v2
diff --git a/docs/documentation.md b/docs/documentation.md
index 2c896c4..cbbc540 100644
--- a/docs/documentation.md
+++ b/docs/documentation.md
@@ -4,7 +4,7 @@
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| 5.1.0 (2021-09-11)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
|Download page| http://pypi.python.org/pypi/decorator/5.1.0|
|Installation| ``pip install decorator``|
|License | BSD license|
diff --git a/setup.py b/setup.py
index de78244..e7b758d 100644
--- a/setup.py
+++ b/setup.py
@@ -30,6 +30,7 @@ if __name__ == '__main__':
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
'Programming Language :: Python :: Implementation :: CPython',
'Topic :: Software Development :: Libraries',
'Topic :: Utilities'],
diff --git a/src/tests/documentation.py b/src/tests/documentation.py
index 85e57ad..ebd55d5 100644
--- a/src/tests/documentation.py
+++ b/src/tests/documentation.py
@@ -14,7 +14,7 @@ doc = r"""# Decorators for Humans
|---|---|
|E-mail | michele.simionato@gmail.com|
|Version| $VERSION ($DATE)|
-|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9|
+|Supports| Python 3.5, 3.6, 3.7, 3.8, 3.9, 3.10|
|Download page| http://pypi.python.org/pypi/decorator/$VERSION|
|Installation| ``pip install decorator``|
|License | BSD license|