summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorMichele Simionato <michele.simionato@gmail.com>2017-07-15 12:30:06 +0200
committerMichele Simionato <michele.simionato@gmail.com>2017-07-15 12:30:06 +0200
commitf068b08cf60cecea4b540d3a36550d0d29455b0e (patch)
treeb26ba30d256099f5e93675afa37b29c9149b962a /Makefile
parentef69f00853d23ede9bb34391b066f674a496be72 (diff)
downloadpython-decorator-git-f068b08cf60cecea4b540d3a36550d0d29455b0e.tar.gz
Generating the documentation for ReadTheDocs
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/Makefile b/Makefile
index 116b2aa..ca45a7a 100644
--- a/Makefile
+++ b/Makefile
@@ -2,15 +2,10 @@ RST=$(S)/ms/tools/rst.py -H
rst: src/tests/documentation.py
PYTHONPATH=src:$(S) $(S)/ms/tools/minidoc.py -d tests.documentation
+ cp /tmp/tests.documentation.rst docs
html: /tmp/tests.documentation.rst docs/README.rst
- $(RST) /tmp/tests.documentation.rst
- $(RST) docs/README.rst
- mv docs/README.html docs/index.html
- mv /tmp/tests.documentation.html docs/documentation.html
+ sphinx-build docs docs/_build
-pdf: /tmp/tests.documentation.rst
- rst2pdf /tmp/tests.documentation.rst -o documentation.pdf
-
-upload: documentation.pdf docs/index.html
- python3 setup.py register sdist bdist_wheel upload upload_docs
+upload: docs/README.rst
+ python3 setup.py sdist bdist_wheel upload