summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorMichele Simionato <michele.simionato@gmail.com>2019-03-16 06:41:08 +0100
committerMichele Simionato <michele.simionato@gmail.com>2019-03-16 06:41:08 +0100
commit4d259b360a1eb7d2ab8c4db9d6becd9c70ec7aaf (patch)
tree74ff596eb06ce5f038d799795188f99c9e1d5839 /README.rst
parent976c5ec2a1453ce2b63e13e885b4d7ab9b34be6a (diff)
downloadpython-decorator-git-4d259b360a1eb7d2ab8c4db9d6becd9c70ec7aaf.tar.gz
Reverted the decorator factory sintax to v4.2 and bumped the release to 4.4
Diffstat (limited to 'README.rst')
-rw-r--r--README.rst92
1 files changed, 0 insertions, 92 deletions
diff --git a/README.rst b/README.rst
deleted file mode 100644
index c0a852a..0000000
--- a/README.rst
+++ /dev/null
@@ -1,92 +0,0 @@
-Decorator module
-=================
-
-:Author: Michele Simionato
-:E-mail: michele.simionato@gmail.com
-:Requires: Python from 2.6 to 3.7
-:Download page: http://pypi.python.org/pypi/decorator
-:Installation: ``pip install decorator``
-:License: BSD license
-
-The goal of the decorator module is to make it easy to define
-signature-preserving function decorators.
-
-Installation
--------------
-
-If you are lazy, just perform
-
- `$ pip install decorator`
-
-which will install just the module on your system.
-
-If you prefer to install the full distribution from source, including
-the documentation, clone the `GitHub repo`_ or download the tarball_, unpack it and run
-
- `$ pip install .`
-
-in the main directory, possibly as superuser.
-
-.. _tarball: http://pypi.python.org/pypi/decorator
-.. _GitHub repo: https://github.com/micheles/decorator
-
-Testing
---------
-
-If you have the source code installation you can run the tests with
-
- `$ python src/tests/test.py -v`
-
-or (if you have setuptools installed)
-
- `$ python setup.py test`
-
-Notice that you may run into trouble if in your system there
-is an older version of the decorator module; in such a case remove the
-old version. It is safe even to copy the module `decorator.py` over
-an existing one, since we kept backward-compatibility for a long time.
-
-Repository
----------------
-
-The project is hosted on GitHub. You can look at the source here:
-
- https://github.com/micheles/decorator
-
-Documentation
----------------
-
-The documentation has been moved to http://decorator.readthedocs.io/en/latest/
-You can download a PDF version of it from http://media.readthedocs.org/pdf/decorator/latest/decorator.pdf
-
-For the impatient
------------------
-
-Here is an example of how to define a family of decorators tracing slow
-operations:
-
-.. code-block:: python
-
- from decorator import decorator
-
- @decorator
- def warn_slow(func, timelimit=60, *args, **kw):
- t0 = time.time()
- result = func(*args, **kw)
- dt = time.time() - t0
- if dt > timelimit:
- logging.warn('%s took %d seconds', func.__name__, dt)
- else:
- logging.info('%s took %d seconds', func.__name__, dt)
- return result
-
- @warn_slow # warn if it takes more than 1 minute
- def preprocess_input_files(inputdir, tempdir):
- ...
-
- @warn_slow(timelimit=600) # warn if it takes more than 10 minutes
- def run_calculation(tempdir, outdir):
- ...
-
-Enjoy!
-