summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Hupp <adam@hupp.org>2021-01-13 10:28:02 -0800
committerGitHub <noreply@github.com>2021-01-13 10:28:02 -0800
commit4274a794423424c2ba7033f82bf1e9224bbba875 (patch)
tree87868fc9f7fa0b1556930a3a9648c27c05054376
parenta96081edc65ddcf20599b3fa1ef72eb2c55f1055 (diff)
parent5d7099f722a4bff3100720781547d2a38930eea3 (diff)
downloadpython-magic-4274a794423424c2ba7033f82bf1e9224bbba875.tar.gz
Merge pull request #229 from eumiro/py39
Add support for Python 3.9
-rw-r--r--.travis.yml1
-rw-r--r--setup.py1
-rw-r--r--test/run.py2
-rw-r--r--tox.ini1
4 files changed, 4 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 7c0ddc8..8253299 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -8,6 +8,7 @@ python:
- "3.6"
- "3.7"
- "3.8"
+ - "3.9"
install:
- pip install coverage
diff --git a/setup.py b/setup.py
index 43c2011..6f40d55 100644
--- a/setup.py
+++ b/setup.py
@@ -35,6 +35,7 @@ setup(name='python-magic',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
],
)
diff --git a/test/run.py b/test/run.py
index c10c11f..a57c21a 100644
--- a/test/run.py
+++ b/test/run.py
@@ -29,4 +29,4 @@ def run_test(versions):
sys.exit("No versions found: " + str(versions))
run_test(["python2", "python2.7"])
-run_test(["python3.5", "python3.6", "python3.7", "python3.8"])
+run_test(["python3.5", "python3.6", "python3.7", "python3.8", "python3.9"])
diff --git a/tox.ini b/tox.ini
index 2d5aa01..6559598 100644
--- a/tox.ini
+++ b/tox.ini
@@ -6,6 +6,7 @@ envlist =
py36,
py37,
py38,
+ py39,
coverage-report,
mypy