summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStevie Gayet <87695919+stegayet@users.noreply.github.com>2023-01-23 16:06:24 +0100
committerGitHub <noreply@github.com>2023-01-23 07:06:24 -0800
commitc7642f02b26f15a5e1bb692d103cadeeeaba9bc1 (patch)
treed378246936e9c6ba0c6248b7becf8169992613a4
parentc7a2e7bc7c387af23b3c896bf05003cf2bd8646b (diff)
downloadpython-magic-c7642f02b26f15a5e1bb692d103cadeeeaba9bc1.tar.gz
chore(tests): add Python 3.10 and 3.11 in CI runs/tox/trove classifier (#284)
-rw-r--r--.travis.yml2
-rw-r--r--setup.py2
-rw-r--r--tox.ini1
3 files changed, 5 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
index 8c306d9..bf4dbaf 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -9,6 +9,8 @@ python:
- "3.7"
- "3.8"
- "3.9"
+ - "3.10"
+ - "3.11"
install:
- pip install coverage coveralls codecov
diff --git a/setup.py b/setup.py
index 06386c3..b7cfdc6 100644
--- a/setup.py
+++ b/setup.py
@@ -39,6 +39,8 @@ setuptools.setup(
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
'Programming Language :: Python :: Implementation :: CPython',
],
)
diff --git a/tox.ini b/tox.ini
index 272d8c5..ae9f02a 100644
--- a/tox.ini
+++ b/tox.ini
@@ -7,6 +7,7 @@ envlist =
py38,
py39,
py310,
+ py311,
mypy
[testenv]