summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Hupp <adam@hupp.org>2021-01-15 12:31:42 -0800
committerGitHub <noreply@github.com>2021-01-15 12:31:42 -0800
commiteccbe10b03d9bed19f5d7e373b3febf9036a4293 (patch)
tree67233b5b0c27c3f5dd3e7470dffd35155a332e8a
parent14cc4e42c665a74906193fb11fda4e6f2bf8ca39 (diff)
parent8c577bd89b0ffa0d7abb1135a76dc7c7fcd5bd89 (diff)
downloadpython-magic-eccbe10b03d9bed19f5d7e373b3febf9036a4293.tar.gz
Merge branch 'master' into redo-compat
-rw-r--r--.travis.yml1
-rw-r--r--README.md20
-rw-r--r--setup.py3
-rw-r--r--test/run.py3
-rw-r--r--tox.ini1
5 files changed, 20 insertions, 8 deletions
diff --git a/.travis.yml b/.travis.yml
index 251f782..688c07d 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -7,6 +7,7 @@ python:
- "3.6"
- "3.7"
- "3.8"
+ - "3.9"
install:
- pip install coverage coveralls codecov
diff --git a/README.md b/README.md
index 044752c..6f1c8dc 100644
--- a/README.md
+++ b/README.md
@@ -57,13 +57,17 @@ that must be installed as well:
### Debian/Ubuntu
- $ sudo apt-get install libmagic1
+```
+sudo apt-get install libmagic1
+```
### Windows
You'll need DLLs for libmagic. @julian-r maintains a pypi package with the DLLs, you can fetch it with:
- $ pip install python-magic-bin
+```
+pip install python-magic-bin
+```
### OSX
@@ -99,15 +103,21 @@ triage it.
To run the tests across 3 recent Ubuntu LTS releases (depends on Docker):
- $ ./test_docker.sh
+```
+./test_docker.sh
+```
To run tests locally across all available python versions:
- $ ./test/run.py
+```
+./test/run.py
+```
To run against a specific python version:
- $ LC_ALL=en_US.UTF-8 python3 test/test.py
+```
+LC_ALL=en_US.UTF-8 python3 test/test.py
+```
## Versioning
diff --git a/setup.py b/setup.py
index 234c8a3..edf0aea 100644
--- a/setup.py
+++ b/setup.py
@@ -12,7 +12,6 @@ def read(file_name):
encoding='utf-8') as f:
return f.read()
-
setup(
name='python-magic',
description='File type identification using libmagic',
@@ -35,6 +34,8 @@ setup(
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: Implementation :: CPython',
],
)
+
diff --git a/test/run.py b/test/run.py
index 48203df..733db4d 100644
--- a/test/run.py
+++ b/test/run.py
@@ -29,5 +29,4 @@ def run_test(versions):
if not found:
sys.exit("No versions found: " + str(versions))
-
-run_test(["python3.5", "python3.6", "python3.7", "python3.8"])
+run_test(["python3.5", "python3.6", "python3.7", "python3.8", "python3.9"])
diff --git a/tox.ini b/tox.ini
index 94a5b4f..0f0ca13 100644
--- a/tox.ini
+++ b/tox.ini
@@ -5,6 +5,7 @@ envlist =
py36,
py37,
py38,
+ py39,
coverage-report,
mypy