summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py52
1 files changed, 26 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index 43c2011..234c8a3 100644
--- a/setup.py
+++ b/setup.py
@@ -12,29 +12,29 @@ def read(file_name):
encoding='utf-8') as f:
return f.read()
-setup(name='python-magic',
- description='File type identification using libmagic',
- author='Adam Hupp',
- author_email='adam@hupp.org',
- url="http://github.com/ahupp/python-magic",
- version='0.4.18',
- py_modules=['magic'],
- long_description=read('README.md'),
- long_description_content_type='text/markdown',
- keywords="mime magic file",
- license="MIT",
- python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*',
- classifiers=[
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.5',
- 'Programming Language :: Python :: 3.6',
- 'Programming Language :: Python :: 3.7',
- 'Programming Language :: Python :: 3.8',
- 'Programming Language :: Python :: Implementation :: CPython',
- ],
- )
+
+setup(
+ name='python-magic',
+ description='File type identification using libmagic',
+ author='Adam Hupp',
+ author_email='adam@hupp.org',
+ url="http://github.com/ahupp/python-magic",
+ version='0.4.18',
+ py_modules=['magic'],
+ long_description=read('README.md'),
+ long_description_content_type='text/markdown',
+ keywords="mime magic file",
+ license="MIT",
+ python_requires='>=3.0',
+ classifiers=[
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ ],
+)