summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakub Szafrański <s@samu.pl>2019-02-12 13:06:15 +0100
committerJakub Szafrański <s@samu.pl>2019-02-12 13:06:15 +0100
commitc58d18a925621f99e21905be9e49a5b55b7bcf30 (patch)
tree165804e4a264ebf5915085106c263e9589cccf1b
parent2439d0a8d7e48750d7b73a0e8da9a3571f6617cc (diff)
downloadpython-memcached-c58d18a925621f99e21905be9e49a5b55b7bcf30.tar.gz
Fix linter errors
-rw-r--r--memcache.py3
-rw-r--r--setup.py5
2 files changed, 6 insertions, 2 deletions
diff --git a/memcache.py b/memcache.py
index bf0feac..72e3cbe 100644
--- a/memcache.py
+++ b/memcache.py
@@ -1440,7 +1440,8 @@ class _Host(object):
if self.socket:
recv = self.socket.recv
else:
- recv = lambda bufsize: b''
+ def recv(*args, **kwargs):
+ return b''
while True:
index = buf.find(b'\r\n')
diff --git a/setup.py b/setup.py
index 93cbe4d..f579be5 100644
--- a/setup.py
+++ b/setup.py
@@ -15,7 +15,10 @@ setup(
maintainer="Sean Reifschneider",
maintainer_email="jafo@tummy.com",
url="https://github.com/linsomniac/python-memcached",
- download_url="https://github.com/linsomniac/python-memcached/releases/download/{0}/python-memcached-{0}.tar.gz".format(version),
+ download_url=(
+ "https://github.com/linsomniac/python-memcached/releases/download/"
+ "{0}/python-memcached-{0}.tar.gz".format(version)
+ ),
py_modules=["memcache"],
install_requires=open('requirements.txt').read().split(),
classifiers=[