summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorAlejandro Cabrera <alejandro.cabrera@rackspace.com>2014-01-15 13:18:16 -0500
committerAlejandro Cabrera <alejandro.cabrera@rackspace.com>2014-01-15 13:18:16 -0500
commitf18df4ea275a0c586ff6fc68cbc9fbdfe7c66874 (patch)
treed24d181d3ee865b19f238268f3ac817c93427f18 /tests
parent794b02811d8c6fdad304955a4602fb1324270f95 (diff)
downloadpython-memcached-f18df4ea275a0c586ff6fc68cbc9fbdfe7c66874.tar.gz
feat(tox): add support for testing with tox
This adds notes in the README and a tox.ini file for use with the tox test manager. This helps greatly towards migrating python-memcached towards python 3.3+ compatibility.
Diffstat (limited to 'tests')
-rw-r--r--tests/Makefile7
-rw-r--r--tests/test_setmulti.py2
2 files changed, 0 insertions, 9 deletions
diff --git a/tests/Makefile b/tests/Makefile
deleted file mode 100644
index a844aa4..0000000
--- a/tests/Makefile
+++ /dev/null
@@ -1,7 +0,0 @@
-TESTS = $(wildcard test_*.py)
-
-test:
- @- $(foreach TEST,$(TESTS), \
- echo === Running test: $(TEST); \
- python $(TEST); \
- )
diff --git a/tests/test_setmulti.py b/tests/test_setmulti.py
index 815ccfd..3607f02 100644
--- a/tests/test_setmulti.py
+++ b/tests/test_setmulti.py
@@ -63,5 +63,3 @@ class test_Memcached_Set_Multi(unittest.TestCase):
if DEBUG:
print 'set_multi({0!r}) -> {1!r}'.format(mapping, bad_keys)
-
-unittest.main()