summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml8
-rw-r--r--README.md3
-rw-r--r--tests/test_setmulti.py2
3 files changed, 11 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..3a3a3f2
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,8 @@
+language: python
+python:
+ - 2.6
+ - 2.7
+ - pypy
+install: python setup.py install
+before_script: pip install nose
+script: nosetests
diff --git a/README.md b/README.md
index 2f29ab7..cd4a69e 100644
--- a/README.md
+++ b/README.md
@@ -1,3 +1,6 @@
+[![Build
+Status](https://travis-ci.org/linsomniac/python-memcached.svg)](https://travis-ci.org/linsomniac/python-memcached)
+
This software is a 100% Python interface to the memcached memory cache
daemon. It is the client side software which allows storing values in one
or more, possibly remote, memcached servers. Search google for memcached
diff --git a/tests/test_setmulti.py b/tests/test_setmulti.py
index 815ccfd..3607f02 100644
--- a/tests/test_setmulti.py
+++ b/tests/test_setmulti.py
@@ -63,5 +63,3 @@ class test_Memcached_Set_Multi(unittest.TestCase):
if DEBUG:
print 'set_multi({0!r}) -> {1!r}'.format(mapping, bad_keys)
-
-unittest.main()