summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.B. Tsai <dbtsai@dbtsai.com>2012-08-22 21:39:55 -0700
committerD.B. Tsai <dbtsai@dbtsai.com>2012-08-27 20:02:49 -0700
commita63b32c7a7673ccfd24593ed69e57e43edfefb1b (patch)
tree5f644b971f84e98fecbea57592e24845e4baa216
parent0ae0ebf94de6366490e0b2ed62d36c0ba5cc5e99 (diff)
downloadpython-mimeparse-a63b32c7a7673ccfd24593ed69e57e43edfefb1b.tar.gz
Uploaded to PyPI using python-mimeparse as package name.
-rw-r--r--LICENSE5
-rw-r--r--MANIFEST5
-rw-r--r--MANIFEST.in1
-rw-r--r--PKG-INFO46
-rw-r--r--README21
-rwxr-xr-xmimeparse.py2
-rwxr-xr-xsetup.py57
7 files changed, 72 insertions, 65 deletions
diff --git a/LICENSE b/LICENSE
index c3f4832..89de354 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,7 +1,3 @@
-
-<!-- saved from url=(0061)http://mimeparse.googlecode.com/svn-history/r21/trunk/LICENSE -->
-<html><head><meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"></head><body><pre style="word-wrap: break-word; white-space: pre-wrap;">Copyright (c) 2010 Joe Gregorio
-
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
@@ -19,4 +15,3 @@ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
-</pre></body></html> \ No newline at end of file
diff --git a/MANIFEST b/MANIFEST
deleted file mode 100644
index d187ea5..0000000
--- a/MANIFEST
+++ /dev/null
@@ -1,5 +0,0 @@
-README
-mimeparse.py
-mimeparse_test.py
-testdata.json
-setup.py
diff --git a/MANIFEST.in b/MANIFEST.in
new file mode 100644
index 0000000..a2dcf40
--- /dev/null
+++ b/MANIFEST.in
@@ -0,0 +1 @@
+include README LICENSE mimeparse_test.py testdata.json
diff --git a/PKG-INFO b/PKG-INFO
index a26fd33..3e4b65e 100644
--- a/PKG-INFO
+++ b/PKG-INFO
@@ -1,15 +1,33 @@
Metadata-Version: 1.1
-Name: mimeparse
-Version: 0.1.3
-Author: Joe Gregorio
-Author-email: joe@bitworking.org
-Maintainer: Joe Gregorio
-Maintainer-email: joe@bitworking.org
-Home-page: http://code.google.com/p/mimeparse/
-Download-url: http://code.google.com/p/mimeparse/downloads/list
-Summary: mimeparse
-License: MIT License
-Description: A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
-Keywords: python mime-type
-Platform: any
-
+Name: python-mimeparse
+Version: 0.1.4
+Summary: A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
+Home-page: https://github.com/dbtsai/python-mimeparse
+Author: David Tsai
+Author-email: dbtsai@dbtsai.com
+License: UNKNOWN
+Download-URL: http://pypi.python.org/packages/source/p/python-mimeparse/python-mimeparse-0.1.4.tar.gz
+Description:
+ This module provides basic functions for handling mime-types. It can handle
+ matching mime-types against a list of media-ranges. See section 14.1 of
+ the HTTP specification [RFC 2616] for a complete explanation.
+
+ http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.1
+
+ Contents:
+ - parse_mime_type(): Parses a mime-type into its component parts.
+ - parse_media_range(): Media-ranges are mime-types with wild-cards and a "q" quality parameter.
+ - quality(): Determines the quality ("q") of a mime-type when compared against a list of media-ranges.
+ - quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
+ - best_match(): Choose the mime-type with the highest quality ("q") from a list of candidates.
+
+Keywords: mime-type
+Platform: UNKNOWN
+Classifier: Programming Language :: Python
+Classifier: Programming Language :: Python :: 3
+Classifier: License :: OSI Approved :: MIT License
+Classifier: Operating System :: OS Independent
+Classifier: Development Status :: 5 - Production/Stable
+Classifier: Intended Audience :: Developers
+Classifier: Topic :: Internet :: WWW/HTTP
+Classifier: Topic :: Software Development :: Libraries :: Python Modules
diff --git a/README b/README
index cd5c8eb..d5c925d 100644
--- a/README
+++ b/README
@@ -1,19 +1,24 @@
-This module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.
+This module provides basic functions for handling mime-types. It can handle
+matching mime-types against a list of media-ranges. See section 14.1 of
+the HTTP specification [RFC 2616] for a complete explanation.
-See section 14.1 of RFC 2616 (the HTTP specification) for a complete explanation.
+ http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.1
+
+Contents:
+ - parse_mime_type(): Parses a mime-type into its component parts.
+ - parse_media_range(): Media-ranges are mime-types with wild-cards and a "q" quality parameter.
+ - quality(): Determines the quality ("q") of a mime-type when compared against a list of media-ranges.
+ - quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
+ - best_match(): Choose the mime-type with the highest quality ("q") from a list of candidates.
Testing
=======
The format of the JSON test data file is as follows:
A top-level JSON object which has a key for each of the functions to be tested. The value corresponding to that key is a list of tests. Each test contains: the argument or arguments to the function being tested, the expected results and an optional description.
-
Python
======
-The Python tests require either Python 2.6 or the installation of the SimpleJSON library.
-
-Installing SimpleJson can be done by:
-sudo easy_install simplejson
+The Python tests require Python 2.6.
Run the tests by typing:
-python mimeparse_test.py
+python mimeparse_test.py \ No newline at end of file
diff --git a/mimeparse.py b/mimeparse.py
index 075272d..9f9a2c1 100755
--- a/mimeparse.py
+++ b/mimeparse.py
@@ -19,7 +19,7 @@ Contents:
"""
from functools import reduce
-__version__ = '0.1.3'
+__version__ = '0.1.4.1'
__author__ = 'Joe Gregorio'
__email__ = 'joe@bitworking.org'
__license__ = 'MIT License'
diff --git a/setup.py b/setup.py
index 0f2821b..2369456 100755
--- a/setup.py
+++ b/setup.py
@@ -1,41 +1,34 @@
#!/usr/bin/env python
-# -*- coding: utf-8 -*-
+import os
+import mimeparse
from setuptools import setup
-setup(
- name='mimeparse',
- version='0.1.3',
- description='A module provides basic functions for parsing mime-type names and matching them against a list of media-ranges.',
- long_description="""
-This module provides basic functions for handling mime-types. It can handle
-matching mime-types against a list of media-ranges. See section 14.1 of
-the HTTP specification [RFC 2616] for a complete explanation.
- http://www.w3.org/Protocols/rfc2616/rfc2616-sec14.html#sec14.1
+def read(fname):
+ return open(os.path.join(os.path.dirname(__file__), fname)).read()
-Contents:
- - parse_mime_type(): Parses a mime-type into its component parts.
- - parse_media_range(): Media-ranges are mime-types with wild-cards and a 'q' quality parameter.
- - quality(): Determines the quality ('q') of a mime-type when compared against a list of media-ranges.
- - quality_parsed(): Just like quality() except the second parameter must be pre-parsed.
- - best_match(): Choose the mime-type with the highest quality ('q') from a list of candidates.
- """,
+setup(
+ name="python-mimeparse",
+ py_modules=["mimeparse"],
+ version=mimeparse.__version__,
+ description=("A module provides basic functions for parsing mime-type "
+ "names and matching them against a list of media-ranges."),
+ author="David Tsai",
+ author_email="dbtsai@dbtsai.com",
+ url="https://github.com/dbtsai/python-mimeparse",
+ download_url=("http://pypi.python.org/packages/source/p/python-mimeparse/"
+ "python-mimeparse-" + mimeparse.__version__ + ".tar.gz"),
+ keywords=["mime-type"],
classifiers=[
- # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: MIT License',
- 'Programming Language :: Python',
- 'Topic :: Internet :: WWW/HTTP',
- 'Topic :: Software Development :: Libraries :: Python Modules',
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Development Status :: 5 - Production/Stable",
+ "Intended Audience :: Developers",
+ "Topic :: Internet :: WWW/HTTP",
+ "Topic :: Software Development :: Libraries :: Python Modules",
],
- keywords='mime-type',
- author='Joe Gregorio',
- author_email='joe@bitworking.org',
- maintainer='Joe Gregorio',
- maintainer_email='joe@bitworking.org',
- url='http://code.google.com/p/mimeparse/',
- license='MIT',
- py_modules=['mimeparse'],
- zip_safe=True,
+ long_description=read('README')
)