summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Tax <paultax@gmail.com>2015-08-24 21:03:03 +0200
committerPaul Tax <paultax@gmail.com>2015-08-24 21:03:03 +0200
commit5be488383fea8b514cedc02ec9b9031bc411107d (patch)
tree470856656e60ce7207bb5cccd6a51989f703b763
parent28973f0821d2fabe5a696d4eed0b2a66925038fe (diff)
downloadpython-requests-aws-5be488383fea8b514cedc02ec9b9031bc411107d.tar.gz
Add travis again
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml12
-rw-r--r--README.md4
-rw-r--r--requirements.txt2
4 files changed, 17 insertions, 3 deletions
diff --git a/.gitignore b/.gitignore
index ca8b11d..0536a1d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,6 @@
.DS_Store
+dist/
+requests_aws.egg-info/
env/
*.pyc
*.*~ \ No newline at end of file
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..1df5645
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,12 @@
+language: python
+python:
+ - "2.6"
+ - "2.6"
+ - "2.7"
+ - "3.2"
+ - "3.3"
+ - "3.4"
+install:
+ - pip install requests
+# command to run tests, e.g. python setup.py test
+script: python test.py \ No newline at end of file
diff --git a/README.md b/README.md
index 8bff852..98b1888 100644
--- a/README.md
+++ b/README.md
@@ -2,7 +2,9 @@
AWS authentication for Amazon S3 for the wonderful [pyhon requests library](http://python-requests.org)
-- Tested with python 2.6 and python 3.3.2
+[![Build Status](https://travis-ci.org/tax/python-requests-aws.svg?branch=master)](https://travis-ci.org/tax/python-requests-aws)
+
+- Tested with python 2.7 and python 3
- At the moment only S3 is supported
## Usage
diff --git a/requirements.txt b/requirements.txt
deleted file mode 100644
index 3a3a480..0000000
--- a/requirements.txt
+++ /dev/null
@@ -1,2 +0,0 @@
-requests==2.7.0
-wheel==0.24.0