summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul <paultax@gmail.com>2012-09-04 19:37:03 +0200
committerPaul <paultax@gmail.com>2012-09-04 19:37:03 +0200
commitb91a58c24233ad131d616a300bd59817770df25d (patch)
tree72bf5dd7d068e6f5e85ded2a983067abbe3f70c1
parent63b98f6927895c28355be13d29f6763257f4283d (diff)
downloadpython-requests-aws-b91a58c24233ad131d616a300bd59817770df25d.tar.gz
test travis
-rw-r--r--.gitignore3
-rw-r--r--.travis.yml6
-rw-r--r--test.py1
3 files changed, 5 insertions, 5 deletions
diff --git a/.gitignore b/.gitignore
index 1f0311e..097e1aa 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
.DS_Store
requests/
-*.pyc \ No newline at end of file
+*.pyc
+*.*~ \ No newline at end of file
diff --git a/.travis.yml b/.travis.yml
index 04ea59a..26f747a 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -4,10 +4,8 @@ python:
- "2.6"
env:
global:
- - secure: "DOCQlFRUEiVQ/Z4r9dRvkI7tStyJVlTJkFp6yOnbH/YK3WveCjIKUv2B79Up\na5TcVi7lvmEFYs8L9Rm+Ms3Z77u36QzhCIY3QwvE7jLf746jWAKZIPwo8xLD\nqia8N6gfjOMElxdbFx0HQSqhCkrWze62+C1g31Nr1NymfGbKhFU="
- - secure: "WZYImZRlT2EvtZOAasxt+zbKeJXp651ncLI8djgE1X/Hy9P2nmDb7yikKhGw\nQE6P/VSPaISVIJ39LZ1dwTmAGV2txmNiSfZ/YPw4CH784O7Y4U9wNsEhcxtd\nyhuRKjJwAZ7ZlVA87ePv38xgdbG/9DjvX4Bsz9yXobJn7SuEJ6U="
-# command to install dependencies, e.g. pip install -r requirements.txt --use-mirrors
+ - secure: "Xk+rgLne+LDucpavGjAI9312X8izrzzoNwb4VW5JjP3yzcmi9eBL2o9NW92o\ng2tLh229cLPBHHaw/GZ5hbUjR9SH9Febl18o8tdyw7YCcJxbSzGKzFN9Wlrb\nYOJOdVoMTSdWKzEZjEDKEn+HI4W+5fhsximOXNYU81P3dgt7s7k="
install:
- pip install requests
# command to run tests, e.g. python setup.py test
-script: python test.py \ No newline at end of file
+script: python test.py
diff --git a/test.py b/test.py
index cb5ff6c..f4c5a9f 100644
--- a/test.py
+++ b/test.py
@@ -14,6 +14,7 @@ if 'AWS_SECRET_KEY' in os.environ:
class TestAWS(unittest.TestCase):
def setUp(self):
+ print os.environ
print ACCESS_KEY[:3], SECRET_KEY[:3]
self.auth=S3Auth(ACCESS_KEY, SECRET_KEY)