summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-04-27 12:08:35 -0400
committerVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-04-27 12:08:35 -0400
commit3f1a0fe7c5775a72141163ccdd593272e512898c (patch)
treee3d529d4956ed162cd3545f6170db08fcfba8199
parent0bf1b8761f695e5ae14d9c439a05b151b4a1093d (diff)
downloadpython-slugify-3f1a0fe7c5775a72141163ccdd593272e512898c.tar.gz
Add cmdLine optionv6.1.2ci
-rw-r--r--CHANGELOG.md4
-rw-r--r--dev.requirements.txt2
-rwxr-xr-xsetup.py3
-rw-r--r--slugify/__version__.py2
4 files changed, 8 insertions, 3 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 12d0ff1..2ba0bb3 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,7 @@
+## 6.1.2
+
+- Reintroduce the cli options
+
## 6.1.1
- Remove type hinting (temporarily)
diff --git a/dev.requirements.txt b/dev.requirements.txt
index 2b4e781..5f94d7b 100644
--- a/dev.requirements.txt
+++ b/dev.requirements.txt
@@ -1,3 +1,3 @@
-pycodestyle==2.7.0
+pycodestyle==2.8.0
twine==3.4.1
flake8==4.0.1 \ No newline at end of file
diff --git a/setup.py b/setup.py
index 8fdb214..c3c4b3b 100755
--- a/setup.py
+++ b/setup.py
@@ -80,5 +80,6 @@ setup(
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
- ]
+ ],
+ entry_points={'console_scripts': ['slugify=slugify.__main__:main']},
)
diff --git a/slugify/__version__.py b/slugify/__version__.py
index f971770..55abc97 100644
--- a/slugify/__version__.py
+++ b/slugify/__version__.py
@@ -5,4 +5,4 @@ __description__ = 'A Python slugify application that also handles Unicode'
__url__ = 'https://github.com/un33k/python-slugify'
__license__ = 'MIT'
__copyright__ = 'Copyright 2022 Val Neekman @ Neekware Inc.'
-__version__ = '6.1.1'
+__version__ = '6.1.2'