summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman <val@neekware.com>2019-09-20 12:41:06 -0400
committerVal Neekman <val@neekware.com>2019-09-20 12:41:06 -0400
commit67c16a409063578d38bf69ee345254e67b237206 (patch)
treef5110013593b4b50929749fc03f90f786da363f7
parent413ac35c0859bf9c6e1024c993c77cb980f9645e (diff)
downloadpython-slugify-67c16a409063578d38bf69ee345254e67b237206.tar.gz
upgrade to consume the latest version of dependencies3.0.4
-rw-r--r--CHANGELOG.md6
-rwxr-xr-xsetup.py4
-rw-r--r--slugify/__init__.py2
3 files changed, 6 insertions, 6 deletions
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 96ed05d..cc98d31 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,6 @@
-## 3.0.3
- - Add Options to readme
- - Add more unit tests
+## 3.0.4
+ - Now supporting text-unidecode>=1.3
+ - Now supporting Unidecode>=1.1.1
## 3.0.2
- Add official support of Py 3.7
diff --git a/setup.py b/setup.py
index 9f49764..83fcf63 100755
--- a/setup.py
+++ b/setup.py
@@ -14,8 +14,8 @@ url = 'https://github.com/un33k/python-slugify'
author = 'Val Neekman'
author_email = 'info@neekware.com'
license = 'MIT'
-install_requires = ['text-unidecode==1.3']
-extras_require = {'unidecode': ['Unidecode==1.0.23']}
+install_requires = ['text-unidecode>=1.3']
+extras_require = {'unidecode': ['Unidecode>=1.1.1']}
classifiers = [
'Development Status :: 5 - Production/Stable',
diff --git a/slugify/__init__.py b/slugify/__init__.py
index c351e2e..52a07b4 100644
--- a/slugify/__init__.py
+++ b/slugify/__init__.py
@@ -3,4 +3,4 @@ from .slugify import *
__author__ = 'Val Neekman @ Neekware Inc. [@vneekman]'
__description__ = 'A Python slugify application that also handles Unicode'
-__version__ = '3.0.3'
+__version__ = '3.0.4'