summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-02-16 16:33:14 -0500
committerVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-02-16 16:33:14 -0500
commit86161b412e4674fcd5bee4c2120d6fe2cd7fa18d (patch)
treef9b23e0816e146df54222019d99a8e968b0586e1
parent97915d932c40b3783dc0064c07f247bba1fb6929 (diff)
downloadpython-slugify-86161b412e4674fcd5bee4c2120d6fe2cd7fa18d.tar.gz
github action
-rw-r--r--.github/workflows/ci.yml21
-rw-r--r--.github/workflows/main.yml21
2 files changed, 22 insertions, 20 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 34ea50c..d4998a5 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -1,5 +1,7 @@
-name: (CI)
+name: CI
+# Run on push only for dev/sandbox
+# Otherwise it may trigger concurrently `push & pull_request` on PRs.
on:
push:
branches:
@@ -7,19 +9,18 @@ on:
jobs:
build:
- name: Setup ${{ matrix.python }} ${{ matrix.os }}
- runs-on: ${{ matrix.os }}
+ name: Python ${{ matrix.python }}
+ runs-on: ubuntu-latest
strategy:
- fail-fast: false
matrix:
- os: [macos-latest, windows-latest, ubuntu-latest]
python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+
steps:
- - name: setup-python ${{ matrix.python }}
+ - uses: actions/checkout@v2
+ - name: setup python
uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python }}
-
- name: Install dependencies
run: |
python -m pip install --upgrade pip
@@ -28,14 +29,14 @@ jobs:
- name: Run flake8
run: |
pip install flake8 --upgrade
- flake8 --exclude=migrations,tests --ignore=E501,E241,E225,E128 .
+ flake8 --exclude=build --ignore=E501,F403,F401,E241,E225,E128 .
- name: Run pycodestyle
run: |
pip install pycodestyle --upgrade
- pycodestyle --exclude=migrations,tests --ignore=E501,E241,E225,E128 .
+ pycodestyle --ignore=E128,E261,E225,E501,W605 slugify test.py setup.py
- name: Run test
run: |
- coverage run --source=python test.py
+ coverage run --source=slugify test.py
- name: Coveralls
run: coveralls --service=github
env:
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index 7b7146b..f1e75b7 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -1,5 +1,7 @@
-name: (CI)
+name: Main
+# Run on push only for dev/sandbox
+# Otherwise it may trigger concurrently `push & pull_request` on PRs.
on:
push:
branches:
@@ -7,19 +9,18 @@ on:
jobs:
build:
- name: Setup ${{ matrix.python }} ${{ matrix.os }}
- runs-on: ${{ matrix.os }}
+ name: Python ${{ matrix.python }}
+ runs-on: ubuntu-latest
strategy:
- fail-fast: false
matrix:
- os: [macos-latest, windows-latest, ubuntu-latest]
python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+
steps:
- - name: setup-python ${{ matrix.python }}
+ - uses: actions/checkout@v2
+ - name: setup python
uses: actions/setup-python@v2
with:
python-version: ${{ matrix.python }}
-
- name: Install dependencies
run: |
python -m pip install --upgrade pip
@@ -28,14 +29,14 @@ jobs:
- name: Run flake8
run: |
pip install flake8 --upgrade
- flake8 --exclude=migrations,tests --ignore=E501,E241,E225,E128 .
+ flake8 --exclude=build --ignore=E501,F403,F401,E241,E225,E128 .
- name: Run pycodestyle
run: |
pip install pycodestyle --upgrade
- pycodestyle --exclude=migrations,tests --ignore=E501,E241,E225,E128 .
+ pycodestyle --ignore=E128,E261,E225,E501,W605 slugify test.py setup.py
- name: Run test
run: |
- coverage run --source=python test.py
+ coverage run --source=slugify test.py
- name: Coveralls
run: coveralls --service=github
env: