summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2022-11-18 20:36:21 +0200
committerGitHub <noreply@github.com>2022-11-18 13:36:21 -0500
commita229e483b6f82f36600e73e7a2fb62dc2f5e7ed3 (patch)
treec80060753bcd69a9e857bcea0c8e1ce03aab7bc0
parentdbe74897764eb8338151e09cfc611e90cef12280 (diff)
downloadpython-slugify-a229e483b6f82f36600e73e7a2fb62dc2f5e7ed3.tar.gz
Add support for Python 3.11 (#121)
* Add support for Python 3.11 * Drop support for EOL Python 3.6
-rw-r--r--.github/workflows/ci.yml6
-rw-r--r--.github/workflows/dev.yml6
-rw-r--r--.github/workflows/main.yml6
-rw-r--r--setup.cfg2
-rwxr-xr-xsetup.py4
5 files changed, 11 insertions, 13 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index 4148354..56e4097 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -14,12 +14,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, "3.10", 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/.github/workflows/dev.yml b/.github/workflows/dev.yml
index d0cb401..73f2f07 100644
--- a/.github/workflows/dev.yml
+++ b/.github/workflows/dev.yml
@@ -14,12 +14,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, "3.10", 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index f1e75b7..a4ae9ad 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -13,12 +13,12 @@ jobs:
runs-on: ubuntu-latest
strategy:
matrix:
- python: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python: [3.7, 3.8, 3.9, "3.10", 3.11, pypy3.8]
steps:
- - uses: actions/checkout@v2
+ - uses: actions/checkout@v3
- name: setup python
- uses: actions/setup-python@v2
+ uses: actions/setup-python@v4
with:
python-version: ${{ matrix.python }}
- name: Install dependencies
diff --git a/setup.cfg b/setup.cfg
deleted file mode 100644
index 3c6e79c..0000000
--- a/setup.cfg
+++ /dev/null
@@ -1,2 +0,0 @@
-[bdist_wheel]
-universal=1
diff --git a/setup.py b/setup.py
index c3c4b3b..65c72f4 100755
--- a/setup.py
+++ b/setup.py
@@ -9,7 +9,7 @@ from setuptools import setup
package = 'slugify'
-python_requires = ">=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, !=3.5.*"
+python_requires = ">=3.7"
here = os.path.abspath(os.path.dirname(__file__))
install_requires = ['text-unidecode>=1.3']
@@ -75,11 +75,11 @@ setup(
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3.8',
'Programming Language :: Python :: 3.9',
'Programming Language :: Python :: 3.10',
+ 'Programming Language :: Python :: 3.11',
],
entry_points={'console_scripts': ['slugify=slugify.__main__:main']},
)