summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-02-16 16:51:48 -0500
committerVal Neekman (AvidCoder) <un33kvu@gmail.com>2022-02-16 16:51:48 -0500
commitc23bbc1dfbd50c64c342f9e6daf488b94639e4ba (patch)
treefc80a08de5afce022677a10d2a7ed79db56e6849
parent7c4802eef3fdd2762d24b7f031f0d0e9305ad15d (diff)
downloadpython-slugify-c23bbc1dfbd50c64c342f9e6daf488b94639e4ba.tar.gz
coverall omit
-rw-r--r--.github/workflows/dev.yml2
-rw-r--r--setup.cfg5
2 files changed, 1 insertions, 6 deletions
diff --git a/.github/workflows/dev.yml b/.github/workflows/dev.yml
index d0cb401..729c26c 100644
--- a/.github/workflows/dev.yml
+++ b/.github/workflows/dev.yml
@@ -37,7 +37,7 @@ jobs:
pycodestyle --ignore=E128,E261,E225,E501,W605 slugify test.py setup.py
- name: Run test
run: |
- coverage run --source=slugify test.py
+ coverage run --include=slugify --omit=__version__.py --source=slugify test.py
- name: Coveralls
run: coveralls --service=github
env:
diff --git a/setup.cfg b/setup.cfg
index 26da821..3c6e79c 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,7 +1,2 @@
[bdist_wheel]
universal=1
-
-[coverage:run]
-include =
- slugify/slugify.py
- slugify/special.py