summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Loria <sloria1@gmail.com>2019-03-31 09:43:39 -0400
committerVal Neekman <un33kvu@gmail.com>2019-03-31 09:43:39 -0400
commitcab1c969e8bed86ab03f61dd04c90c376267988d (patch)
tree6423b43f3352b4ea42a34d84fe89a4afcb7a6363
parent98c83bee0900751d37fd70c1a048cdd85ca034c4 (diff)
downloadpython-slugify-cab1c969e8bed86ab03f61dd04c90c376267988d.tar.gz
Test against Python 3.7 (#75)
Also, remove `sudo: false` because TravisCI has migrated to their VM-based infrastructure: https://blog.travis-ci.com/2018-11-19-required-linux-infrastructure-migration
-rw-r--r--.travis.yml5
-rwxr-xr-xsetup.py1
2 files changed, 4 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
index 685386f..695c4b9 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,12 +1,13 @@
-sudo: false
language: python
+dist: xenial
python:
- "2.7"
- "3.4"
- "3.5"
- "3.6"
- - pypy
+ - "3.7"
+ - "pypy2.7-6.0"
install:
- pip install pip -U
diff --git a/setup.py b/setup.py
index a78b672..4800173 100755
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,7 @@ classifiers = [
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
]