summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVal Neekman <val@neekware.com>2019-03-31 10:09:55 -0400
committerVal Neekman <val@neekware.com>2019-03-31 10:09:55 -0400
commitf70d438067df8e3a50d37e27ff1236e2cf69b6fb (patch)
tree4784baa32ca5e4ac3f0f057317cd9c54b780fd7f
parente364a529de8528ed263cd4b9e075fa7ea282ddf8 (diff)
parent1a9c6a928591f9d515e62201d6c3bc9ed1f479f1 (diff)
downloadpython-slugify-f70d438067df8e3a50d37e27ff1236e2cf69b6fb.tar.gz
add py 3.7 support
-rw-r--r--.travis.yml6
-rw-r--r--CHANGELOG.md3
-rwxr-xr-xsetup.py1
-rw-r--r--slugify/__init__.py2
4 files changed, 9 insertions, 3 deletions
diff --git a/.travis.yml b/.travis.yml
index 685386f..c821af2 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,12 +1,14 @@
-sudo: false
language: python
+dist: xenial
python:
- "2.7"
- "3.4"
- "3.5"
- "3.6"
- - pypy
+ - "3.7"
+ - "pypy2.7-6.0"
+ - "pypy3.5-6.0"
install:
- pip install pip -U
diff --git a/CHANGELOG.md b/CHANGELOG.md
index a426d10..82ed7ba 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,6 @@
+## 3.0.2
+ - Add official support of Py 3.7
+
## 3.0.1
- Add test.py to manifest
diff --git a/setup.py b/setup.py
index a78b672..4800173 100755
--- a/setup.py
+++ b/setup.py
@@ -32,6 +32,7 @@ classifiers = [
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
]
diff --git a/slugify/__init__.py b/slugify/__init__.py
index 3ad56fe..0859113 100644
--- a/slugify/__init__.py
+++ b/slugify/__init__.py
@@ -3,4 +3,4 @@ from .slugify import *
__author__ = 'Val Neekman @ Neekware Inc. [@vneekman]'
__description__ = 'A Python slugify application that also handles Unicode'
-__version__ = '3.0.1'
+__version__ = '3.0.2'