summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-02-27 11:50:36 -0800
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2022-08-13 17:02:37 +0200
commit44f7d195364aef52bb311e7420e8f7b59b2d7e5f (patch)
tree3f3d90b9126a23e1a599d22318b263be61de6d10
parent04ee44d230b292b9f7353b20362c7ae6a669c985 (diff)
downloadpython-systemd-44f7d195364aef52bb311e7420e8f7b59b2d7e5f.tar.gz
setup.py: switch from distutils to setuptools
In Python 3.10, distutils is deprecated and slated for removal in Python 3.12. It also prevents 'setup.py bdist_wheel' from building a wheel. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 099819b..fe9c03a 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
import sys, os
-from distutils.core import setup, Extension
+from setuptools import setup, Extension
from subprocess import Popen, PIPE, check_output
def call(*cmd):