summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-12-12 20:15:05 -0500
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2016-12-13 20:27:47 -0500
commite4ff9e6f7cd1a5e1607803e805859c88545f4860 (patch)
tree86f88f3f275990d0e54d621c1f6dbf9667a71ea2
parent0af056c35f4ea9f008f81d85f2542b16e7b4fadf (diff)
downloadpython-systemd-e4ff9e6f7cd1a5e1607803e805859c88545f4860.tar.gz
build-sys: add sign and upload targets
-rw-r--r--Makefile8
-rw-r--r--NEWS1
2 files changed, 7 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index b10d6d9..b4923e3 100644
--- a/Makefile
+++ b/Makefile
@@ -39,6 +39,9 @@ install:
dist:
$(PYTHON) setup.py sdist
+sign: dist/systemd-python-$(VERSION).tar.gz
+ gpg --detach-sign -a dist/systemd-python-$(VERSION).tar.gz
+
clean:
rm -rf build systemd/*.so systemd/*.py[co] *.py[co] systemd/__pycache__
@@ -57,7 +60,10 @@ www_target = www.freedesktop.org:/srv/www.freedesktop.org/www/software/systemd/p
doc-sync:
rsync -rlv --delete --omit-dir-times build/html/ $(www_target)/
+upload: dist/systemd-python-$(VERSION).tar.gz dist/systemd-python-$(VERSION).tar.gz.asc
+ twine-3 upload $+
+
TAGS: $(shell git ls-files systemd/*.[ch])
$(ETAGS) $+
-.PHONY: build install dist clean distclean TAGS doc-sync
+.PHONY: build install dist sign upload clean distclean TAGS doc-sync
diff --git a/NEWS b/NEWS
index e5534eb..1816843 100644
--- a/NEWS
+++ b/NEWS
@@ -11,7 +11,6 @@ CHANGES WITH 233:
Contributions from Robert James Hernandez,
Zbigniew Jędrzejewski-Szmek
-
CHANGES WITH 232:
* Wrappers for sd_journal_enumerate_unique, has_runtime_files,