summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorDavid Strauss <david@davidstrauss.net>2012-09-06 16:45:52 -0700
committerDavid Strauss <david@davidstrauss.net>2012-09-06 16:45:52 -0700
commit7ba24b5802998873df59bdb83b870897567be38e (patch)
tree4c77ea21ee053741b7fb9e3400cd1cb6fd196949 /setup.py
parent05bdd8ce12357776e2f6794d59f4f49e6d85d6b8 (diff)
downloadpython-systemd-7ba24b5802998873df59bdb83b870897567be38e.tar.gz
Make installable.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 4d8839c..bd4402f 100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,13 @@
from distutils.core import setup, Extension
-cjournald = Extension('journald/_journald',
+cjournal = Extension('systemd/_journal',
libraries = ['systemd-journal'],
- sources = ['journald/_journald.c'])
+ sources = ['systemd/_journal.c'])
-setup (name = 'journald',
+setup (name = 'systemd',
version = '0.1',
- description = 'Native interface to the journald facilities of systemd',
+ description = 'Native interface to the facilities of systemd',
author_email = 'david@davidstrauss.net',
- url = 'https://github.com/davidstrauss/journald-python',
- py_modules = ['journald'],
- ext_modules = [cjournald])
+ url = 'https://github.com/systemd/python-systemd',
+ py_modules = ['systemd.journal'],
+ ext_modules = [cjournal])