summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS20
-rw-r--r--setup.py2
2 files changed, 21 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index f5a5760..318628d 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,25 @@
Python wrappers for libsystemd API
+CHANGES WITH 232:
+
+ * Wrappers for sd_journal_enumerate_unique, has_runtime_files,
+ has_peristent_files.
+
+ * sd_journal_open_directory_fd, sd_journal_open_files_fd can
+ be used by passing file descriptors to the initializer as
+ the path or files arguments.
+
+ SD_JOURNAL_OS_ROOT flag is supported, and various flags may
+ be passed to the constructor in combination with path or
+ files arguments. All flags arguments are now passed through
+ to the underlying libsystemd library functions, so which
+ combinations are supported depends on that library.
+ systemd 232 contains various fixes in this area.
+
+ Contributions from: Benedit Morbach, Michael Biebl,
+ Michael Herold, Mike Gilbert, Nir Soffer, Sebastian,
+ Ville Skyttä, Zbigniew Jędrzejewski-Szmek
+
CHANGES WITH 231:
* Various build fixes and cleanups: documentation can be
diff --git a/setup.py b/setup.py
index 326d6b4..c4150dd 100644
--- a/setup.py
+++ b/setup.py
@@ -40,7 +40,7 @@ def lib(*names, **kw):
+ '\n'.join(results) + '\n')
sys.exit(status)
-version = '231'
+version = '232'
defines = {'define_macros':[('PACKAGE_VERSION', '"{}"'.format(version))]}
_journal = Extension('systemd/_journal',