summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--NEWS17
-rw-r--r--setup.py2
2 files changed, 18 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index 1816843..6daac80 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,22 @@
Python wrappers for libsystemd API
+CHANGES WITH 234:
+
+ * Support for the new sd_is_socket_sockaddr added in systemd 233
+ is added.
+
+ * New id128 constants added in systemd 233 are included.
+
+ * "Extra" fields for the log entry can be passed during
+ LoggerAdapter initialization or for each message separately.
+ Fields specified for the message have higher priority.
+
+ * Small fixes and style tweaks all over.
+
+ Contributions from: Park Jeongsoo, Jimmy Cao, Johannes
+ Weberhofer, Mike Gilbert, Oleksii Shevchuk, Ville Skyttä,
+ Wesley Bowman, Zbigniew Jędrzejewski-Szmek
+
CHANGES WITH 233:
* Tests are fixed and should pass on various old and new
diff --git a/setup.py b/setup.py
index 70c2780..983eecd 100644
--- a/setup.py
+++ b/setup.py
@@ -45,7 +45,7 @@ def lib(*names, **kw):
+ '\n'.join(results) + '\n')
sys.exit(status)
-version = '233'
+version = '234'
defines = {'define_macros':[('PACKAGE_VERSION', '"{}"'.format(version))]}
_journal = Extension('systemd/_journal',