summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 678f412..26f75b8 100644
--- a/Makefile
+++ b/Makefile
@@ -17,9 +17,8 @@ builddir := $(shell $(PYTHON) -c '$(buildscript)')
all: build
.PHONY: update-constants
-update-constants: $(INCLUDE_DIR)/systemd/sd-messages.h
- cat $< systemd/id128-defines.h | \
- $(SED) -n -r '/#define SD_MESSAGE_[A-Z0-9_]/p' | \
+update-constants: update-constants.py $(INCLUDE_DIR)/systemd/sd-messages.h
+ $(PYTHON) $+ systemd/id128-defines.h | \
sort -u | \
tee systemd/id128-defines.h.tmp | \
$(SED) -n -r 's/,//g; s/#define (SD_MESSAGE_[A-Z0-9_]+)\s.*/add_id(m, "\1", \1) JOINER/p' | \